Author Topic: Debugging with VS2003 Toolkit  (Read 3671 times)

cpsmusic

  • Guest
Debugging with VS2003 Toolkit
« on: April 21, 2006, 11:31:32 am »
Hi,

I'm new to Code::Blocks. I'm working on Windows XP. I've set up Code::Blocks to use two compilers--GCC and the VS2003 Toolkit compiler. I also have the full VS2003 version installed.

What I'm unclear about is how to set the debugger for VS2003. I've set up GDB for GCC and it works properly. What debugger do I use with VS2003?

Cheers,

Chris


PChris

  • Guest
Re: Debugging with VS2003 Toolkit
« Reply #1 on: April 21, 2006, 02:24:41 pm »
I think cdb.exe

Offline Frank3000

  • Multiple posting newcomer
  • *
  • Posts: 17
Re: Debugging with VS2003 Toolkit
« Reply #2 on: April 21, 2006, 02:52:15 pm »
Klingon multitasking systems do not support 'time-sharing'. When a Klingon program wants to run,
it challenges the scheduler in hand-to-hand combat and owns the machine.

Chris Share

  • Guest
Re: Debugging with VS2003 Toolkit
« Reply #3 on: April 21, 2006, 03:49:56 pm »
Thanks,

I've downloaded and installed the Debugging Tools for Windows.

I'm having a problem setting the path to the correct directory for cdb.exe. If I open Settings -> Compiler -> Programs I can set the Debugger option to cdb.exe. I then set an Additional Path to C:\Program File\Debugging Tools for Windows. When I try to debug the program I get a message saying that the debugger executable is not set.

What am I doing wrong here?

Cheers,

Chris

Jon Moore

  • Guest
Re: Debugging with VS2003 Toolkit
« Reply #4 on: May 31, 2006, 12:44:32 am »
I'm having the same problem with the debugger directory not being set.  Anyone know how to set this up correctly?

Offline BordRider

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: Debugging with VS2003 Toolkit
« Reply #5 on: June 01, 2006, 04:29:36 pm »
Turns out there are a couple of places to set this option (I think):

Project > Build Options

and

Settings > Compiler and Debugger

You've probably already figured it out, but when I was getting started it took me a while to realize that I needed to set the compiler and its options in the project settings since I started the project before I set the compiler in the main settings. 

I could be totally off base but fiddling with that did get it running for me.