Author Topic: Slow perfomance on linux (Ubuntu Dapper)  (Read 33304 times)

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #30 on: August 28, 2006, 10:49:27 am »
Hello again,
For the whole summer I dropped my desktop pc and grabbed my laptop where I have also installed ubuntu with the same almost configuration. I thought that this "bug" was fixed because everything worked perfect on it. Now that I am back, I tried latest C::B on my desktop pc, and I understand that this "bug" appears only on the desktop pc (which is 2 times faster than laptop).

All I am saying is that this is not "an-all-ubuntu" bug, but I cannot understand what's the prob with those individuals pc's.
maybe wrong Xorg conf?
Tell me a bug and I 'll tell you two  :twisted:

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #31 on: August 28, 2006, 11:24:37 am »
Maybe the graphics card driver? Can you try changing X to use the framebuffer driver on your desktop PC and see if it still crashes?
Be patient!
This bug will be fixed soon...

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #32 on: August 29, 2006, 05:58:51 am »
1st of all, It's not a crash!

It is just slow, when I type fast the characters appear five-five and not one-by-one. When I move the mouse around inside the text editor I get 100% cpu usage.

I did the following:
 * reconfigured xorg to get back the default xorg.conf of ubuntu
  Used the "nv" driver and retarted X bla bla...
  Results: the same exactly promblem
 * Tried to use the "fbdev" driver (You told me something about the framebuffer driver, this you mean?)
  Couldn't start x with various of problems that I cannot solve
 * restarted X with my usual xorg.conf and DISABLE everyplugin (even compiler)
  I opened a c++ file with some code and tried to write...
  Results: the same
 * (GNOME:) I went at system->preferences->fonts and disabled hinting and smoothing of fonts (really ugly but font rendering is way faster)
  Results: C::B was exactly the same slow when typing scrolling etc!

I don't know what's the prob, I am now preparing to build a custom kernel to see if thing changed. On the other hand I am looking around at ubuntu forums as well to find a solution.

(I am here to do whetever tests you want ;) )
Tell me a bug and I 'll tell you two  :twisted:

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #33 on: August 29, 2006, 08:36:12 am »
Quote
1st of all, It's not a crash!

Yes, sorry I mixed it with another problem mentioned the same day.
Did you read this post (maybe it helps)?
Be patient!
This bug will be fixed soon...

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #34 on: August 29, 2006, 09:18:35 am »
(If you mean to try profiling..)
Yes I read it... but I cant spent time now for that, I just want to make it work to finish a couple of exercises I have to do for my university. (dipli eksetastiki klp.  sry)

(If you mean to upgrade to >libcairo-1.2.2) I must do many tricky thinks to stay at dapper or upgrade at edgy. Both ways sound very unstable for my main pc :S

« Last Edit: August 29, 2006, 09:21:21 am by sque »
Tell me a bug and I 'll tell you two  :twisted:

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #35 on: August 29, 2006, 09:54:57 am »
Tried something more:

I checked out the svn tree and compiled it using:
CXXFLAGS="-O3 -march=athlon-xp -pipe"

removed deb package and did make install bla bla
Result: THE SAME, maybe a very very small differnce but it still slow

Tell me a bug and I 'll tell you two  :twisted:

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #36 on: August 29, 2006, 10:36:29 am »
You have an NVidia, right?
Be patient!
This bug will be fixed soon...

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #37 on: August 29, 2006, 03:13:04 pm »
Athlon XP 2.2+/Via chipset/ 1GB ram /Nvidia FX 5700 128mb
Tell me a bug and I 'll tell you two  :twisted:

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #38 on: August 29, 2006, 04:27:10 pm »
OK I installed sysprof (It was really easy to use it, as I was afraid :p)
I save 2 logs, one when moving mouse around, and one when I was typing text. I attached them for review by the experts (You need sysprof to open them in a human readable way)

[attachment deleted by admin]
Tell me a bug and I 'll tell you two  :twisted:

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #39 on: August 29, 2006, 04:36:24 pm »
Sry for the many small post... I am not doing it to increase my Posts counter :p
It is because I see something more and more that I think I must post.


Here is another sysprof log when I scroll text up and down with mouse wheel, which is very laggy.
If I move the scroll wheel fast 5 times up-down I need 15seconds to finish moving!

[attachment deleted by admin]
Tell me a bug and I 'll tell you two  :twisted:

sethjackson

  • Guest
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #40 on: August 29, 2006, 06:57:05 pm »
Are you using the proprietary nVidia driver???

I have OpenBSD + X.Org 6.9 + GeForce2 MX/MX 400, and it works fine. :)
I have't compiled C::B on it yet because the wx version is at 2.4.2 for OpenBSD.....
« Last Edit: August 29, 2006, 07:13:28 pm by sethjackson »

Offline sque

  • Multiple posting newcomer
  • *
  • Posts: 65
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #41 on: August 29, 2006, 10:14:40 pm »
Everything else works fine for my pc... at least that it looks like.

Are you using the proprietary nVidia driver???
Yes I am running on proprietary drivers 8762

part of my /var/log/Xorg.0.log
Code: [Select]
[email protected]:~$ cat /var/log/Xorg.0.log | grep NVIDIA
(**) |   |-->Device "NVIDIA Corporation NV36 [GeForce FX 5700]"
(II) Module glx: vendor="NVIDIA Corporation"
(II) Module nvidia: vendor="NVIDIA Corporation"
(II) NVIDIA X Driver  1.0-8762  Mon May 15 13:09:21 PDT 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(--) Chipset NVIDIA GPU found
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): NVIDIA GPU GeForce FX 5700 at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.36.20.19.06
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce FX 5700 at PCI:1:0:0:
(--) NVIDIA(0):     Samsung SyncMaster (CRT-1)
(--) NVIDIA(0): Samsung SyncMaster (CRT-1): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-1
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1280x1024"
(II) NVIDIA(0):     "1024x768"
(II) NVIDIA(0):     "800x600"
(II) NVIDIA(0):     "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): DPI set to (95, 96); computed from "UseEdidDpi" X config option
(II) NVIDIA(0): Setting mode "1280x1024"
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)

glxgears works with 5000 fps. I can run Xgl with no problem of speed and everything works perfect... I can see video...
Tell me a bug and I 'll tell you two  :twisted:

Offline Game_Ender

  • Lives here!
  • ****
  • Posts: 551
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #42 on: August 29, 2006, 11:59:21 pm »
I am not at my Linux machine right now, but lets not just guess its graphics driver.  I use ATI and I do have the problem.  I think the best thing would be to do as sque has already started, compare sysprof profiles of the same activity.  For example scrolling through a very long project file (everyone would do the same one from the CB project), or just continuously typing for for 1 to 2 minutes.  Then we can see where the people with the slowdown spend there time.

I found the biggest chunck of time was spent in pango invoked by scintilla.  Sque, I suggest you just give sysprof a try its not to hard to figure out how it works and would probably a good learning experience.  Sysprof shows you a tree view of each running process and how much of its time was spent in each branch (each branch being a function with its subbranches being the functions it calls).  You have to find the one which is codeblocks and go from there.

sethjackson

  • Guest
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #43 on: August 30, 2006, 03:29:37 am »
Has anyone tried SciTE on a *nix box, and compared it to C::B on the same *nix box?
I may try to compile Scintilla and SciTE soon to see if it is slow....
« Last Edit: August 30, 2006, 03:49:56 am by sethjackson »

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: Slow perfomance on linux (Ubuntu Dapper)
« Reply #44 on: August 30, 2006, 04:12:05 am »
Has anyone tried SciTE on a *nix box, and compared it to C::B on the same *nix box?
I may try to compile Scintilla and SciTE soon to see if it is slow....
And let's not forget wyoEditor too (since it may be a wxScintilla issue).

http://wyoguide.sourceforge.net/downloads.html