Author Topic: default compiler setting  (Read 4823 times)

Offline aguai

  • Single posting newcomer
  • *
  • Posts: 9
default compiler setting
« on: April 08, 2006, 05:00:00 pm »
it seems I lost my default compiler setting

anyone tells me how to reinstall this?

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: default compiler setting
« Reply #1 on: April 08, 2006, 08:56:26 pm »
Hello,

Which C::B/OS version?

Can you explain what do you exactly mean by "I lost my default compiler setting"? Did not work the button "Reset defaults" in Settings-->Compiler and debugger?

Best wishes,
Michael

Offline aguai

  • Single posting newcomer
  • *
  • Posts: 9
Re: default compiler setting
« Reply #2 on: April 09, 2006, 04:13:55 pm »
sorry

my Im using win32 version

I clumsyly change the gcc default into cygwin dir

and then

every exe file become fail....

let say....

it outputs wrong answer....

and I cannot get the default back because i reset that into default

so everything about gcc is wrong...

I have to include <iostream.h> but firmly <iostream>
:P

so...

plz give tell me how to pure reinstall this....

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: default compiler setting
« Reply #3 on: April 09, 2006, 09:40:03 pm »
Hello,

I assume you have MinGW installed by yourself. Then the best thing would be to:

1) Settings-->Compiler and debugger-->Programs tab-->GNU GCC Compiler
2) Under Compiler's installation directory, you put the directory where MinGW is installed, e.g., C:\MinGW.

Alternatively you can try with the Auto-detect button and see if it works.

If you do not have MinGW installed by yourself (not the one that come with RC2), I would advice to download it (installer MinGW 5.0.2) and install it (the candidate release). Then you try Auto-detect or you manually select the MinGW home directory.

If you have problems, just post them here :).

Best wishes,
Michael

Offline fredo

  • Single posting newcomer
  • *
  • Posts: 3
default compiler setting
« Reply #4 on: April 12, 2006, 02:03:41 pm »
Hi!

I am learning the language c in Windows.
i have downloaded and installed "codeblocks-1.0rc2_mingw.exe". But by compiling the simplest program "hello wordl" i receive the next error message:
--------------------------------------------------------------------------------
Switching to target: default
Linking console executable: U:\C_programm\third\console.exe
mingw32-g++.exe: no input files
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings


Could anyone help me please? 

thanks!!

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: default compiler setting
« Reply #5 on: April 12, 2006, 03:22:31 pm »
[...]i have downloaded and installed "codeblocks-1.0rc2_mingw.exe". But by compiling the simplest program "hello wordl"[...]

Hello,

I would give a try to the latest nightly build. Moreover, I would suggest you to install MinGW separately.

Best wishes,
Michael

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: default compiler setting
« Reply #6 on: April 12, 2006, 03:25:47 pm »
I am learning the language c in Windows.
...
Could anyone help me please?

Next time you have a problem, start a new topic.
It's not nice to hijack an existing topic like that, for two reasons:
  • The OP (original poster) won't be happy about it, since instead for answers to his problem he will see answers to yours...
  • It's easier for someone who will have the same problem as you in the future, to find the solution. Else he 'll have to search in topics with subjects irrelevant to the specific problem...

With that said, go to project properties and add your source files to the target you 're trying to compile.
Be patient!
This bug will be fixed soon...