Author Topic: bad windres parameter  (Read 7450 times)

#!/ussr/bin/restart

  • Guest
bad windres parameter
« on: October 13, 2004, 07:32:38 pm »
C::B passes `-J' instead of `-I' key (input format) to the resource compiler:
Code: [Select]
$(RESCOMP) -i <...>.rc -J rc -o $(default_RESOURCE) -O coff  --include-dir=<...>

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
bad windres parameter
« Reply #1 on: October 13, 2004, 08:47:46 pm »
It's easy to change it:

1) Go to "Settings/Configure plugins/Compiler" to view the global compiler options.
2) Click the "Other" tab and then click "Advanced options...".
3) Click "Yes" in the warning dialog that appears.
4) Select "Compile Win32 resource file" in the "Available commands" listbox.
5) Change "-J" to "-I". The line should now read:
Code: [Select]
$rescomp -i $file -I rc -o $resource_output -O coff $res_includes

That's it!
Be patient!
This bug will be fixed soon...

Anonymous

  • Guest
bad windres parameter
« Reply #2 on: October 13, 2004, 09:36:57 pm »
Thanks!

P.S.
I know it's deprecated, but still...

Anonymous

  • Guest
bad windres parameter
« Reply #3 on: October 13, 2004, 09:47:14 pm »
Oh! I almost forgot my manners...

It's a great project, long life to it!