Author Topic: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10  (Read 12275 times)

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #15 on: March 19, 2006, 11:22:05 pm »
--> that will be the next revision, and the nightly build will be based on that one.

Could you commit them so that I will build another .deb package?

Thank you :).

Best wishes,
Michael

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #16 on: March 19, 2006, 11:38:51 pm »
commited

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #17 on: March 19, 2006, 11:41:11 pm »
commited

Great. Thanks :D.

Best wishes,
Michael

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #18 on: March 19, 2006, 11:43:03 pm »
could you try with out the updates (or uncomment the lines in copystrings.cpp) and remove the following line from your copystring-unix.cbp :
         <Add option='-include &quot;sdk.h&quot;' />

[EDIT] : Question : why do we need that option ??

Thanks
« Last Edit: March 19, 2006, 11:52:14 pm by killerbot »

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #19 on: March 20, 2006, 10:01:43 am »
could you try with out the updates (or uncomment the lines in copystrings.cpp) and remove the following line from your copystring-unix.cbp :
         <Add option='-include &quot;sdk.h&quot;' />

Ok. I finish to build C::B and .deb package and I will give it a try :).

Best wishes,
Michael

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #20 on: March 20, 2006, 05:40:41 pm »
could you try with out the updates (or uncomment the lines in copystrings.cpp) and remove the following line from your copystring-unix.cbp :
         <Add option='-include &quot;sdk.h&quot;' />

Ok. I finish to build C::B and .deb package and I will give it a try :).

Best wishes,
Michael


any news on this ??

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #21 on: March 20, 2006, 06:57:41 pm »
any news on this ??

Sorry, I am a bit late in my report :oops:.

What I have is the following:

  • Delete SDK and wxSmith PCH
  • Modify the copystring-unix.cbp as suggested
  • Modify the copystring.cbp as suggested
  • Build C::B
  • Build Contr. plugins

Copystrings project compiles fine :D.

Best wishes,
Michael

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #22 on: March 21, 2006, 10:08:12 am »
So the code seems to be ok (heheh    :D   ) , I will uncomment it again this evening.
And I will adjust that one unix cbp file.
@Yiannis, Thomas : do you know why we needed that include sdk.h compiler option in the unix cbp ??

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #23 on: March 21, 2006, 10:32:36 am »
We don't need it if the #include in the source file is uncommented and not disabled by a preprocessor directive. I don't know who put it there or why.

It does the exact same thing as #include (except for a neglegible difference in search path order).
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #24 on: March 21, 2006, 10:45:42 am »
the thing is, if that directive is there, and the code also has the include (this latter case is IMHO the correct way) we get errors (as described in the start of this topic).
Yiannis told me that such an error also shows up if you include "sdk.h" in a header file, but in this situation that was not the case.
I noticed other plug-ins also have this directive, well I'll adjust them when I clean the the headers includes of those plug-ins.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #25 on: March 21, 2006, 11:18:01 am »
committed : rev 2220

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: [Linux] Error compiling the copystrings (Unix) on Ubuntu 5.10
« Reply #26 on: March 21, 2006, 11:19:04 am »
But it is really the exact same thing (except that the CWD is searched first, which does not matter in this case, as it is identical with the source file's directory):

Quote from: gcc documentation
Process file as if #include "file" appeared as the first line of the primary source file. However, the first directory searched for file is the preprocessor's working directory instead of the directory containing the main source file. If not found there, it is searched for in the remainder of the #include "..." search chain as normal.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."