Author Topic: Toolbars corrupted using wxWidgets 2.6.1  (Read 3232 times)

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9595
Toolbars corrupted using wxWidgets 2.6.1
« on: March 18, 2006, 05:08:04 pm »
I recently compiled C::B using wxWidgets in version 2.6.1 and 2.6.3-RC1 and then back to 2.6.2 for this:
http://forums.codeblocks.org/index.php?topic=2582.0
Now I have a problem: Allthough I re-compiled C::B from scratch several times now my toolbars are corrupted in a way that they are far too wide (see the image attached). I also tried to delete the layout(s) for resetting this but it didn't work, too. The problem is still existent. I also tried to remove the config file but this doesn't help, too. Does anyone have an idea how to resolve this?
With regards, Morten.
[img=http://img206.imageshack.us/img206/1570/toolbarcorrupted3ev.th.png]
Ps.: Version 1.0 revision 2213 (gcc 3.4.4 Windows/unicode, build: Mar 18 2006 15:24:23), "About" says wxWidgts 2.6.2 in addition.
« Last Edit: March 18, 2006, 05:11:45 pm by MortenMacFly »
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9595
Re: Toolbars corrupted using wxWidgets 2.6.1
« Reply #1 on: March 19, 2006, 10:58:13 am »
Does really nobody have an idea? :(
I really wonder how this can happen. I did not re-compile the wxWidgets libs as of version 2.6.1, only re-compiled C::B. It was working with this setup for ages before. How can suddenly the toolbars be too wide? Is the toolbar setup saved somewhere in the registry, maybe? Where?
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2252
Re: Toolbars corrupted using wxWidgets 2.6.1
« Reply #2 on: March 19, 2006, 03:28:40 pm »
Quote
now my toolbars are corrupted in a way that they are far too wide

I have experienced this. But only because I was fooling around
with the toolbars code and specifying wxWindow::SetToolBar(m_pToolbar).
It caused the same problem.

But I dont see how just changing libs causes it. Have you tried
a "clean" CB re-build. Ie, trash the ...\output ...\devel directories
and re-build?


Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9595
Re: Toolbars corrupted using wxWidgets 2.6.1
« Reply #3 on: March 19, 2006, 03:41:13 pm »
Have you tried a "clean" CB re-build. Ie, trash the ...\output ...\devel directories and re-build?
Yes, and that's exactly what really makes me wonder: I've removed the object directory, the ouput, the devel and all *.a and *.gch files. So it's really in fact a complete re-build from scratch. I even removed the wxWidgets directories 2.6.1 and 2.6.3-RC1 completely not to interfer somehow (allthough the path setup is alright) but still the toolbars are like that. I can really only imagine the toolbar parameters are recalled from the registry or something like that. Not to forget: I also removed the C::B settings file...
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9595
[Solved] Toolbars corrupted using wxWidgets 2.6.1
« Reply #4 on: March 20, 2006, 07:08:48 pm »
Alright, I found the reason: When I compiled wxWidgets version 2.6.3 the DLL was copied to my Windows system32 folder. Because this is before my "own" DLL folder in the PATH I was all the way using the wxWidgets 2.6.3 DLL, also with the 2.6.2 build. removing the DLL from the system32 folder made my toolbars look like it was before - with normal size.
BTW: With wxWidgets version 2.6.3-RC2 the toolbars are still corrupted (see http://forums.codeblocks.org/index.php?topic=2666.0 as well...)
Thanks for the help anyway!
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ