Author Topic: Vague Startup error  (Read 6006 times)

Offline ahluka

  • Single posting newcomer
  • *
  • Posts: 5
Vague Startup error
« on: March 18, 2006, 05:45:07 pm »
Hey all,

I've just installed C::B on Fedora Core 4 - all went well but when I go to start it, I get this error message:

Quote
Something has gone wrong inside Code::Blocks and it will terminate immediately.
We are sorry for the inconvenience...

Did I miss something? I haven't restarted or logged out after installation but didn't think it was necessary.
Help!

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Vague Startup error
« Reply #1 on: March 18, 2006, 06:11:48 pm »
Hello,

which version of C::B did you try to install? Did you compile the sources by yourself or use a package (if yes which and where did you take it)?

Best wishes,
Michael

Offline ahluka

  • Single posting newcomer
  • *
  • Posts: 5
Re: Vague Startup error
« Reply #2 on: March 18, 2006, 06:24:42 pm »
I just realised what I think might be the problem. I downloaded an .rpm (I've lost the link) without noticing it's for FC3 and I'm using FC4. So now I'm just in the process of building it myself (codeblocks-1.0rc2) but I'm having trouble getting configure to run:

Quote
...
checking whether to build the to-do plugin... yes
checking whether to build the contrib plugins... yes
checking if the compiler supports precompiled headers... yes
checking for wx-config... /usr/bin/wx-config
checking for wxWindows version >= 2.4.2... yes (version 2.4.2)
configure: Configuring Code::Blocks...
configure: creating ./config.status
config.status: creating Makefile
.infig.status: error: cannot find input file: Makefile

I don't understand why this is happening.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Vague Startup error
« Reply #3 on: March 18, 2006, 06:41:06 pm »
I just realised what I think might be the problem. I downloaded an .rpm (I've lost the link) without noticing it's for FC3 and I'm using FC4. So now I'm just in the process of building it myself (codeblocks-1.0rc2) but I'm having trouble getting configure to run:

You can try to use Daniel2000 package for Fedora Core 4/5 or try to buils SVN sources of C::B (not RC2 version) (here and here).

Best wishes,
Michael
« Last Edit: March 18, 2006, 06:43:30 pm by Michael »

Offline ahluka

  • Single posting newcomer
  • *
  • Posts: 5
Re: Vague Startup error
« Reply #4 on: March 18, 2006, 06:44:07 pm »
I get this error when trying to install:

Quote
Packages not found: libwx_baseu-2.6.so.0

Is that something to do with wxWidgets? I just installed wxGTK 2.4.2.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Vague Startup error
« Reply #5 on: March 18, 2006, 06:46:42 pm »
I get this error when trying to install:

Quote
Packages not found: libwx_baseu-2.6.so.0

Is that something to do with wxWidgets? I just installed wxGTK 2.4.2.

You should install version 2.6.x. In Fedora I am not sure, but in ubuntu 5.10 I have installed 3 packages for wxGTK 2.6.1 (IIRC) + wx-common package (check if you need this too).

Best wishes,
Michael

Offline ahluka

  • Single posting newcomer
  • *
  • Posts: 5
Re: Vague Startup error
« Reply #6 on: March 18, 2006, 07:06:55 pm »
Ok this is really starting to annoy me now. When running configure for wxGTK 2.6.2 I get this error:

Quote
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

I've installed everything around the sun to do with GTK+. I've also set LD_LIBRARY_PATH to the two things it's given me.
This isn't my day :(

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: Vague Startup error
« Reply #7 on: March 18, 2006, 07:13:00 pm »
Ok this is really starting to annoy me now. When running configure for wxGTK 2.6.2 I get this error:

Quote
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

I've installed everything around the sun to do with GTK+. I've also set LD_LIBRARY_PATH to the two things it's given me.
This isn't my day :(

Have you installed the -dev packages? ie. gtk+-2.0-dev.

If you don't feel like compiling yourself, download the FC4 package from here: http://developer.berlios.de/project/showfiles.php?group_id=5358.

Requires original Fedora wxGTK packages e.g. from Freshrpms: http://ftp.freshrpms.net/pub/freshrpms/ayo/fedora/linux/4/i386/RPMS.freshrpms/


Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Vague Startup error
« Reply #8 on: March 18, 2006, 07:19:19 pm »
What I have when building C::B for the first time, was to install the wxGTK that come with ubuntu 5.10 (gnome) and the wx-common package. I have not installed a separate download of wxGTK (though I have it successfully configured). Check with your package manager if you have installed wxGTK 2.6.x and wx-common. Also check this (taken from here):

Quote
What is not covered here, is the wxWidgets prerequisites. The most important being GTK2, of course! Let me stress it here, while it's early: GTK2 is required, not GTK1, for Code::Blocks to be operational.

Also make sure that you have GCC, etc. installed.

After downloading SVN sources with SVN (I have had to install this too), you have to do:

Quote
./bootstrap
./configure
make
make install

Using the wxGTK package is the easiest way (it was for me). Also follow the 2 wiki articles I have referenced in one of my post above.

Best wishes,
Michael

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Vague Startup error
« Reply #9 on: March 18, 2006, 07:20:04 pm »
You might would like to check this out too:

http://forums.codeblocks.org/index.php?topic=2479.0

Best wishes,
Michael
« Last Edit: March 18, 2006, 07:22:33 pm by Michael »

Offline ahluka

  • Single posting newcomer
  • *
  • Posts: 5
Re: Vague Startup error
« Reply #10 on: March 18, 2006, 07:21:40 pm »
Ok this is really starting to annoy me now. When running configure for wxGTK 2.6.2 I get this error:

Quote
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

I've installed everything around the sun to do with GTK+. I've also set LD_LIBRARY_PATH to the two things it's given me.
This isn't my day :(

Have you installed the -dev packages? ie. gtk+-2.0-dev.

If you don't feel like compiling yourself, download the FC4 package from here: http://developer.berlios.de/project/showfiles.php?group_id=5358.

Requires original Fedora wxGTK packages e.g. from Freshrpms: http://ftp.freshrpms.net/pub/freshrpms/ayo/fedora/linux/4/i386/RPMS.freshrpms/


Thanks I've got it working now. I had to yum remove gtk+ first but meh, as long as I've got a working solid IDE.

Offline Game_Ender

  • Lives here!
  • ****
  • Posts: 551
Re: Vague Startup error
« Reply #11 on: March 19, 2006, 05:34:20 pm »
*Offtopic*

wxGTK that come with ubuntu 5.10 (gnome) and the wx-common package.

Just on linux note, Ubuntu is a debian based distribution and it using gnome has nothing to do with this conversation.  The important difference between Fedora Core and Ubuntu in this conversation (and all ones that involve linux software configurations) is that one is based on debian, and the other is Red Hat's unstable version of there Enterprise Linux.  So the whole basis for package organization and install locations is different.