Author Topic: The 06 march 2006 build is out.  (Read 17939 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 06 march 2006 build is out.
« on: March 06, 2006, 11:37:07 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml
A link to the unicode windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26u_gcc_cb.7z
For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://download.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26_gcc_cb.7z

The 06 March 2006 build is out.
  - Windows : http://download.berlios.de/codeblocks/CB_20060306_rev2143_win32.7z
  - Linux : not supported yet


Resolved Fixed:

  • Overloaded another log function
  • Added NSIS lexer (patch #898)
  • Updated XBase lexer (patch #893)

Regressions/Confirmed/Annoying/Common bugs:

  • DDE bug : clicking in windows explorer on a CB registered file throws an error message box
  • toolbar-images-not-changing-state (is a wx problem)
  • there are several issues with Code Completion (is being redesigned : work in progress)

« Last Edit: March 07, 2006, 09:49:33 pm by killerbot »

Offline netzmeister

  • Single posting newcomer
  • *
  • Posts: 7
    • The Developers Source
Re: The 06 march 2006 build is out.
« Reply #1 on: March 06, 2006, 11:38:51 pm »
Hi,
yes, i can confirm the  "code completion bug".
I will have a look at the DDE bug..

netzmeister

Offline davereid20

  • Multiple posting newcomer
  • *
  • Posts: 16
    • DaveWeb
Re: The 06 march 2006 build is out.
« Reply #2 on: March 06, 2006, 11:50:11 pm »
yes, i can confirm the  "code completion bug".
I will have a look at the DDE bug..

netzmeister,
I believe these have already been confirmed.  They've been discussed several times in the forum.
Windows XP Pro SP2
Code::Blocks Nightly SVN
wxWidgets 2.6.2 Unicode MinGW 3.4.5 Candidate

sethjackson

  • Guest
Re: The 06 march 2006 build is out.
« Reply #3 on: March 07, 2006, 12:21:54 am »
That is why the are under the "Regressions/Confirmed/Annoying/Common bugs:" title. :D

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 06 march 2006 build is out.
« Reply #4 on: March 07, 2006, 12:23:03 am »
well feel free to look at it, hey even very closely, maybe you know how to fix it. The last time I looked at it, I got stuck, probably not enough knowledge on the DDE thing ... ;-)

sethjackson

  • Guest
Re: The 06 march 2006 build is out.
« Reply #5 on: March 07, 2006, 12:28:51 am »
Wheres the link that explains the DDE bug? Yeah I know it says "DDE bug : clicking in windows explorer on a CB registered file throws an error message box", but I have yet to reproduce it????

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 06 march 2006 build is out.
« Reply #6 on: March 07, 2006, 12:36:04 am »
one way I have encountered it :

- no cb open
- double click on registered file (eg .cpp)
- cb will open the file BUT in the meantime it shows an error screen saying it can not find the file

most of the time it does not happen anymore, sometimes it pops up again.

Another user wrote (I still have not tried this, shame on me), he can easily reconstruct this when he has the tip of the day active (I have that disabled).


sethjackson

  • Guest
Re: The 06 march 2006 build is out.
« Reply #7 on: March 07, 2006, 12:39:04 am »
one way I have encountered it :

- no cb open
- double click on registered file (eg .cpp)
- cb will open the file BUT in the meantime it shows an error screen saying it can not find the file

most of the time it does not happen anymore, sometimes it pops up again.

Another user wrote (I still have not tried this, shame on me), he can easily reconstruct this when he has the tip of the day active (I have that disabled).



Ok tip of the day is disabled for me too. Umm this bug is at random no?

Offline idcarlos

  • Multiple posting newcomer
  • *
  • Posts: 23
Re: The 06 march 2006 build is out.
« Reply #8 on: March 07, 2006, 12:40:02 am »
one way I have encountered it :

- no cb open
- double click on registered file (eg .cpp)
- cb will open the file BUT in the meantime it shows an error screen saying it can not find the file

most of the time it does not happen anymore, sometimes it pops up again.

Another user wrote (I still have not tried this, shame on me), he can easily reconstruct this when he has the tip of the day active (I have that disabled).

Same bug under my Windows XP.
żI can do any test to help to fix it?

sethjackson

  • Guest
Re: The 06 march 2006 build is out.
« Reply #9 on: March 07, 2006, 12:41:21 am »
Ok I deleted default.conf, opened the CodeBlocks.cbp under WinXP Pro got this bug pretty random????  :?

sethjackson

  • Guest
Re: The 06 march 2006 build is out.
« Reply #10 on: March 07, 2006, 12:43:04 am »
WOW.  :shock: It happens every time if I have the tip of the day show on app startup. Could it be related?

Offline netzmeister

  • Single posting newcomer
  • *
  • Posts: 7
    • The Developers Source
Re: The 06 march 2006 build is out.
« Reply #11 on: March 07, 2006, 12:44:45 am »
The problem exists only under Win32.
Under Linux i cannot reproduce it.
I will boot Win32 and take a look at the Code..

bidoll

  • Guest
Re: The 06 march 2006 build is out.
« Reply #12 on: March 07, 2006, 12:59:17 am »
I can't download it...
The message report that couldn't connect.
Is that my problem???

Offline netzmeister

  • Single posting newcomer
  • *
  • Posts: 7
    • The Developers Source
Re: The 06 march 2006 build is out.
« Reply #13 on: March 07, 2006, 01:28:14 am »
The problem exists only under Win32.
Under Linux i cannot reproduce it.
I will boot Win32 and take a look at the Code..

Hmm, i can't reproduce it on my WinXP!

When i try to debug the program..
Code: [Select]
Program received signal SIGSEGV, Segmentation fault.
( winundef.h line 311 )

Any suggestions?

netzmeister

Offline TheNullinator

  • Multiple posting newcomer
  • *
  • Posts: 42
Re: The 06 march 2006 build is out.
« Reply #14 on: March 07, 2006, 05:56:34 am »
Hi,

I've submitted a patch to BerliOS (https://developer.berlios.de/patch/index.php?func=detailpatch&patch_id=902&group_id=5358) for the DDE bug when "Tip of the Day" is enabled.  It seems to work fine (in Windows XP SP2, at least) if you create the DDE server before displaying a modal dialog box (any modal dialog caused the bug, not just the "Tip of the Day" dialog).

The patch is just a simple shuffle of code in src/src/app.cpp.

Cheers

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 06 march 2006 build is out.
« Reply #15 on: March 07, 2006, 07:35:09 am »
Hi,

I've submitted a patch to BerliOS (https://developer.berlios.de/patch/index.php?func=detailpatch&patch_id=902&group_id=5358) for the DDE bug when "Tip of the Day" is enabled.  It seems to work fine (in Windows XP SP2, at least) if you create the DDE server before displaying a modal dialog box (any modal dialog caused the bug, not just the "Tip of the Day" dialog).

The patch is just a simple shuffle of code in src/src/app.cpp.

Cheers

wooohooo, this sounds great. I will try it out this evening and apply the patch then.
And the DDE-oscar goes to ....... TheNullinator. ;-)

Now let's all hope we never had it when there were no tips displayed, I can't remember anymore.

Can't wait to get home this evening .....

Offline skirby

  • Almost regular
  • **
  • Posts: 137
Re: The 06 march 2006 build is out.
« Reply #16 on: March 07, 2006, 10:11:52 am »
Hi,

I've submitted a patch to BerliOS (https://developer.berlios.de/patch/index.php?func=detailpatch&patch_id=902&group_id=5358) for the DDE bug when "Tip of the Day" is enabled.  It seems to work fine (in Windows XP SP2, at least) if you create the DDE server before displaying a modal dialog box (any modal dialog caused the bug, not just the "Tip of the Day" dialog).

The patch is just a simple shuffle of code in src/src/app.cpp.

Cheers

Several days ago, I have post something about that http://forums.codeblocks.org/index.php?topic=2400.msg18924#msg18924

Someone told me that there is no relation between Tip of the Day and the bug you talk about.
But, since I uncheck Tip of the Day at startup, I have no more problem.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: The 06 march 2006 build is out.
« Reply #17 on: March 07, 2006, 10:42:34 am »
Someone told me that there is no relation between Tip of the Day and the bug you talk about.

Hello,

For waht I have understood, the bug seems related to modal dialog boxes in general and not specifically with "Tip of the Day".

Best wishes,
Michael

Offline TheNullinator

  • Multiple posting newcomer
  • *
  • Posts: 42
Re: The 06 march 2006 build is out.
« Reply #18 on: March 07, 2006, 11:05:58 am »
Yeah, it's appears to be modal dialogs in general.  The same problem occurs for MessageBox and wsSafeShowMessage.  I didn't test it with non-modal dialogs.

Offline Zingam

  • Multiple posting newcomer
  • *
  • Posts: 74
Re: The 06 march 2006 build is out.
« Reply #19 on: March 07, 2006, 01:58:16 pm »
:) Maybe you should test it and report.


Could this be a MS bug or wxWidgets one?

sethjackson

  • Guest
Re: The 06 march 2006 build is out.
« Reply #20 on: March 07, 2006, 02:18:05 pm »
WOOHOO It's in. :D Kudos to TheNullinator.  8)

Offline TheNullinator

  • Multiple posting newcomer
  • *
  • Posts: 42
Re: The 06 march 2006 build is out.
« Reply #21 on: March 07, 2006, 02:25:50 pm »
:) Maybe you should test it and report.

Could this be a MS bug or wxWidgets one?

By doing some googling, it seems to be a M$ Windows bug.  :)  It seems to have hiccups with modals and DDE.

Offline netzmeister

  • Single posting newcomer
  • *
  • Posts: 7
    • The Developers Source
Re: The 06 march 2006 build is out.
« Reply #22 on: March 07, 2006, 06:59:22 pm »
:) Maybe you should test it and report.

Could this be a MS bug or wxWidgets one?

By doing some googling, it seems to be a M$ Windows bug.  :)  It seems to have hiccups with modals and DDE.
Let's see the link!
Is there nothing we can do?

netzmeister

Offline TheNullinator

  • Multiple posting newcomer
  • *
  • Posts: 42
Re: The 06 march 2006 build is out.
« Reply #23 on: March 07, 2006, 09:02:55 pm »
Here are two:

http://www.angelfire.com/biz/rhaminisys/support.html#ExecTestProblem

That one describes a problem like Code::Blocks had.  It seems to use a DDE server control written in VB.

http://blogs.msdn.com/oldnewthing/archive/2005/02/28/381591.aspx#381627

This person indicates he has had trouble with DDE and modals at startup.

That was what a found from a quick search.  Some more comprehensive information may be found if you tried harder.  It seems, though, that setting up the DDE server prior to displaying a modal works.

Cheers

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 06 march 2006 build is out.
« Reply #24 on: March 07, 2006, 09:43:54 pm »
hehe, home, and Yiannis already fixed it; that's easy ....  8)

Offline quantufinity

  • Single posting newcomer
  • *
  • Posts: 3
Re: The 06 march 2006 build is out.
« Reply #25 on: March 08, 2006, 05:11:50 am »
Hi All,

Is it possible to have an "SVN" like repository for binary files? I am thinking that I only need to download files that have changed since the last nightly build. Just a thought but will likely save time for those of us who are using dial-up connection.

Thanks,
Quantufinity

Offline Game_Ender

  • Lives here!
  • ****
  • Posts: 551
Re: The 06 march 2006 build is out.
« Reply #26 on: March 08, 2006, 05:35:16 am »
That would help some, and I will have to check this but I think most of the space is taken up by the executable, libraries, and pluggins.  The only thing you don't need to update every time is the images and wxWidgets library.  I am not sure how space the image take up but I think that they aren't a very big chunk.  So I am not sure how useful it would be.