Author Topic: CodeBlocks project file for RakNet  (Read 6340 times)

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
CodeBlocks project file for RakNet
« on: March 03, 2006, 11:36:08 am »
Hello,

RakNet version 2.454 now includes a project file for CodeBlocks :D. This project generates at the moment only shared libraries (Dlls) both in "debug" and in "release". Please also note that to compile RakNet you should use GCC 3.4.5 (older, but not too old, GCC version should also work), but not GCC 4.1.0 (or not at the moment). I am working in my free time (:)) to improve it and extends it to include new targets (e.g., static libraries).

Thank you.

Best wishes,
Michael

Offline Game_Ender

  • Lives here!
  • ****
  • Posts: 551
Re: CodeBlocks project file for RakNet
« Reply #1 on: March 03, 2006, 08:56:01 pm »
RakNet works fine with GCC 4.0.1 on linux.  I built up a set of project files for it, but I did it without all that extra audio baggage.

Offline frankmail007

  • Multiple posting newcomer
  • *
  • Posts: 23
Re: CodeBlocks project file for RakNet
« Reply #2 on: March 04, 2006, 06:43:36 am »
I'm using CB's default compiler. The version is "gcc version 3.4.4 (mingw special)". It failed to compile RakNet 2.454. The error message is like this:

Include/RSACrypt.h:1043:   instantiated from `void big::generateStrongPseudoPrime(T&) [with T = big::word[4]]'
Include/RSACrypt.h:1099:   instantiated from `void big::RSACrypt<T>::generateKeys() [with T = big::word[8]]'
Source\RakPeer.cpp:364:   instantiated from here

Any clue for this?

Thanks

Offline frankmail007

  • Multiple posting newcomer
  • *
  • Posts: 23
Re: CodeBlocks project file for RakNet
« Reply #3 on: March 04, 2006, 10:57:31 am »
I upgrade my gcc to 3.45. Still got the same problem. By the way, there is another error "alloca undeclared".

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: CodeBlocks project file for RakNet
« Reply #4 on: March 04, 2006, 09:07:44 pm »
RakNet works fine with GCC 4.0.1 on linux.  I built up a set of project files for it, but I did it without all that extra audio baggage.

May be on Linux (I did not give a try on it), but when I have tried with GCC 4.1.0 (on Windows), I have got some problems. By compiling with GCC 3.4.5, I did got some warnings (and instanciated here problems), but it worked.

Best wishes,
Michael

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: CodeBlocks project file for RakNet
« Reply #5 on: March 04, 2006, 09:11:27 pm »
I'm using CB's default compiler. The version is "gcc version 3.4.4 (mingw special)". It failed to compile RakNet 2.454. The error message is like this:

Include/RSACrypt.h:1043:   instantiated from `void big::generateStrongPseudoPrime(T&) [with T = big::word[4]]'
Include/RSACrypt.h:1099:   instantiated from `void big::RSACrypt<T>::generateKeys() [with T = big::word[8]]'
Source\RakPeer.cpp:364:   instantiated from here

Any clue for this?

Thanks

I got also some of these. But they are not "errors" (I have thought the same at the beginning), because I got built my DLL. Check if the building process generates the DLL.

Best wishes,
Michael

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: CodeBlocks project file for RakNet
« Reply #6 on: March 04, 2006, 09:13:37 pm »
I upgrade my gcc to 3.45. Still got the same problem. By the way, there is another error "alloca undeclared".

About this I am not sure. I got some problems, but no "errors". Check if the building process creates the DLL.

Anyway, IMHO you should also upgrade win32api files (and may be binutils files too).

Best wishes,
Michael

Offline frankmail007

  • Multiple posting newcomer
  • *
  • Posts: 23
Re: CodeBlocks project file for RakNet
« Reply #7 on: March 05, 2006, 06:04:29 am »
Problem fixed. The version 2.455 is released. You'll find the latest version on RakNet's home page.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: CodeBlocks project file for RakNet
« Reply #8 on: March 05, 2006, 07:49:23 pm »
Problem fixed. The version 2.455 is released. You'll find the latest version on RakNet's home page.

There seems to be a small confusion with the version numbers. In the readme.txt file, the version is 2.455, but in the RakNet forum the latest version annonced is the 2.454 :?.

Best wishes,
Michael

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: CodeBlocks project file for RakNet
« Reply #9 on: March 05, 2006, 09:30:24 pm »
RakNet works fine with GCC 4.0.1 on linux.  I built up a set of project files for it, but I did it without all that extra audio baggage.

May be on Linux (I did not give a try on it), but when I have tried with GCC 4.1.0 (on Windows), I have got some problems. By compiling with GCC 3.4.5, I did got some warnings (and instanciated here problems), but it worked.

After a modification suggested by the project's administrator and the correction of a couple of extra qualification errors, RaKNet now compiles with GCC 4.1.0 :D. Anyway, the changes are not yet commited. Probably for the next release.

Best wishes,
Michael