Author Topic: Built file is not running on any terminal expect xtem  (Read 951 times)

Offline cscodeprince

  • Single posting newcomer
  • *
  • Posts: 1
Built file is not running on any terminal expect xtem
« on: June 02, 2020, 03:25:43 pm »
I am using centos 8. I have installed CodeBlocks recently using flatpak. Everything is working perfect. I want to change the default xterm terminal. I tried to change it from Environment but didn't work. Here are some details about my installation-

[[email protected] bin]$ pwd
/var/lib/flatpak/app/org.codeblocks.codeblocks/current/active/files/bin
[[email protected] bin]$ ls
cb_console_runner  codeblocks  resize  xterm
cb_share_config    koi8rxterm  uxterm

As you can see the path of the installation folder and there is no terminal here expect xterm

When I run a simple hello world program, the build log prints
Executing: 'gnome-terminal -t '/home/praj/Desktop/Prog/hello11' -x  '/app/bin/cb_console_runner' '/home/praj/Desktop/Prog/hello11'' (in '/home/praj/Desktop/Prog')
Process terminated with status -1 (0 minute(s), 3 second(s))

I have tried everything I found on the internet. Could anyone help me?

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2756
Re: Built file is not running on any terminal expect xtem
« Reply #1 on: June 02, 2020, 04:45:28 pm »
I do not know many things about flatpack and i do not think that we provide a official release with it?

Isn't flatpack isolating the executable from the outside operating system in a sandbox, so you can not run anything from the outside of this sandbox
as long as you do not add it specifically in your application? So i do not think this is possible in a quick way...

https://unix.stackexchange.com/questions/412869/how-to-allow-gui-application-in-flatpak-to-run-cli-tool

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2756
Re: Built file is not running on any terminal expect xtem
« Reply #2 on: June 02, 2020, 04:48:06 pm »
I have no unix system at the hand at the moment, so i do not know if you can add "free" terminals. if so, you can try to put
Code: [Select]
flatpak-spawn --host in front of it

But i do not know if you have to modify some permissions (i suspect so)

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2756
Re: Built file is not running on any terminal expect xtem
« Reply #3 on: June 02, 2020, 04:51:19 pm »
Probably this can help too https://blogs.gnome.org/wjjt/2018/08/07/using-vundle-from-the-vim-flatpak/

Edit:
1) I wonder if it would be possible to run the host compiler with this command. For sure hell of imperformat but it could work
2) I wonder what compiler the flatpack uses
3) I wonder if you can use system libraries within the flatpack codeblocks...


Where did you get the codeblocks flatpack?
« Last Edit: June 02, 2020, 04:54:02 pm by BlueHazzard »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12685
    • Travis build status
Re: Built file is not running on any terminal expect xtem
« Reply #4 on: June 02, 2020, 09:43:51 pm »
I am using centos 8. I have installed CodeBlocks recently using flatpak.
Using codeblocks from flatpak doesn't work.
Vanilla codeblocks requires major changes to make it actually work.
If you have problem with a flatpak version of Code::Blocks please report them to the vendor which made the flatpak.
He/she/it is doing major hacks to make it work.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]