Author Topic: Build and run  (Read 207 times)

Offline RosscO

  • Single posting newcomer
  • *
  • Posts: 2
Build and run
« on: March 23, 2020, 03:09:39 am »
Hi

After reading the manual and doing a bit of programming for a while I suddenly lose the "lights" on the Build and Run buttons.  What I've done seems to save okay.  I have to then shut Code Blocks down and restart the program, open Previous Projects and from there I can carry on again from whence I left off.  Any advice please?

Thanks in advance

RosscO

Online stahta01

  • Lives here!
  • ****
  • Posts: 6794
    • My Best Post
Re: Build and run
« Reply #1 on: March 23, 2020, 05:07:15 am »
The "lights" go out when the built program is running.

Exit you built program or if needed kill it in the task manager.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2600
Re: Build and run
« Reply #2 on: March 23, 2020, 08:23:39 am »
Also try to update codeblocks. There was a bug where you could not terminate running programms (The red cross button did not work) In the latest nightly you should be able to use the red button near the build button to stop your program

Offline RosscO

  • Single posting newcomer
  • *
  • Posts: 2
Re: Build and run
« Reply #3 on: March 24, 2020, 01:20:46 am »
Thanks folks.  Your advice is appreciated.

RosscO