Author Topic: ubuntu : "wxSmith plugin is not loaded, can not continue"  (Read 323 times)

Offline paddle

  • Single posting newcomer
  • *
  • Posts: 8
ubuntu : "wxSmith plugin is not loaded, can not continue"
« on: March 01, 2020, 08:04:31 am »
Hey guys,
I just moved to ubuntu from win7 and I'm trying to setup my CB + wxWidgets and I'm meeting an issue here.

When I try to create a new wxWidgets I get the error message : wxSmith plugin is not loaded, can not continue

It sounds like wxSmith plugin is not installed. ThoughI think it's installed:

For the installation I used this tutorial : https://www.linuxbabe.com/ubuntu/install-code-blocks-ubuntu-16-04-17-04
I used the second methode described there as it said Software's version is old (though now that I checked it does not seems so.)
Code: [Select]
wget http://sourceforge.net/projects/codeblocks/files/Binaries/17.12/Linux/Debian%20stable/codeblocks_17.12-1_amd64_stable.tar.xz
sudo tar xvf codeblocks_17.12-1_amd64_stable.tar.xz
sudo apt install ./codeblocks_17.12-1_amd64.deb ./codeblocks-common_17.12-1_all.deb ./libcodeblocks0_17.12-1_amd64.deb ./codeblocks-dev_17.12-1_amd64.deb ./codeblocks-headers_17.12-1_all.deb ./*wx*.deb

I checked my home folder and seen some wxsmith .deb, I tried to install those but console feedback they are already installed.

What I am doing wrong?

I'm using wxWidgets 3.1.3. I also use Xubuntu that I installed on top of ubuntu. Not sure if these can be an issue?

If I try to run again the command to install I get :
Code: [Select]
sudo apt install ./codeblocks_17.12-1_amd64.deb ./codeblocks-common_17.12-1_all.deb ./libcodeblocks0_17.12-1_amd64.deb ./codeblocks-dev_17.12-1_amd64.deb ./codeblocks-headers_17.12-1_all.deb ./*wx*.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'codeblocks' instead of './codeblocks_17.12-1_amd64.deb'
Note, selecting 'codeblocks-common' instead of './codeblocks-common_17.12-1_all.deb'
Note, selecting 'libcodeblocks0' instead of './libcodeblocks0_17.12-1_amd64.deb'
Note, selecting 'codeblocks-dev' instead of './codeblocks-dev_17.12-1_amd64.deb'
Note, selecting 'codeblocks-headers' instead of './codeblocks-headers_17.12-1_all.deb'
Note, selecting 'codeblocks-libwxcontrib0' instead of './codeblocks-libwxcontrib0_17.12-1_amd64.deb'
Note, selecting 'codeblocks-wxcontrib-dev' instead of './codeblocks-wxcontrib-dev_17.12-1_amd64.deb'
Note, selecting 'codeblocks-wxcontrib-headers' instead of './codeblocks-wxcontrib-headers_17.12-1_all.deb'
Note, selecting 'libwxsmithlib0' instead of './libwxsmithlib0_17.12-1_amd64.deb'
Note, selecting 'libwxsmithlib0-dev' instead of './libwxsmithlib0-dev_17.12-1_amd64.deb'
Note, selecting 'wxsmith-dev' instead of './wxsmith-dev_17.12-1_amd64.deb'
Note, selecting 'wxsmith-headers' instead of './wxsmith-headers_17.12-1_all.deb'
codeblocks is already the newest version (17.12-1).
codeblocks-common is already the newest version (17.12-1).
codeblocks-dev is already the newest version (17.12-1).
codeblocks-headers is already the newest version (17.12-1).
codeblocks-libwxcontrib0 is already the newest version (17.12-1).
codeblocks-wxcontrib-dev is already the newest version (17.12-1).
codeblocks-wxcontrib-headers is already the newest version (17.12-1).
libcodeblocks0 is already the newest version (17.12-1).
libwxsmithlib0 is already the newest version (17.12-1).
libwxsmithlib0-dev is already the newest version (17.12-1).
wxsmith-dev is already the newest version (17.12-1).
wxsmith-headers is already the newest version (17.12-1).
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
« Last Edit: March 01, 2020, 08:06:07 am by paddle »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12321
    • Travis build status
Re: ubuntu : "wxSmith plugin is not loaded, can not continue"
« Reply #1 on: March 01, 2020, 10:51:21 am »
You need to install codeblocks-contrib.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline paddle

  • Single posting newcomer
  • *
  • Posts: 8
Re: ubuntu : "wxSmith plugin is not loaded, can not continue"
« Reply #2 on: March 01, 2020, 01:48:39 pm »
Thanks for your feedback!

Which package? There are a so many different packages. A monolithic install would make things simpler for new-comers.
codeblocks_17.12-1_amd64.deb
codeblocks-common_17.12-1_all.deb
codeblocks-contrib_17.12-1_amd64.deb
codeblocks-contrib-common_17.12-1_all.deb
codeblocks-dev_17.12-1_amd64.deb
codeblocks-headers_17.12-1_all.deb
codeblocks-libwxcontrib0_17.12-1_amd64.deb
codeblocks-wxcontrib-dev_17.12-1_amd64.deb
codeblocks-wxcontrib-headers_17.12-1_all.deb
libcodeblocks0_17.12-1_amd64.deb
libwxsmithlib0_17.12-1_amd64.deb
libwxsmithlib0-dev_17.12-1_amd64.deb
wxsmith-dev_17.12-1_amd64.deb
wxsmith-headers_17.12-1_all.deb

Is it contrib or contrib-common? Or  libwxcontrib or wx-contrib-dev or wx-contrib-headers?

I tried to install contrib and got some errors :
Code: [Select]
sudo apt install ./codeblocks-contrib_17.12-1_amd64.deb
[sudo] password for pierre:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'codeblocks-contrib' instead of './codeblocks-contrib_17.12-1_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codeblocks-contrib : Depends: libboost-system1.62.0 but it is not installable
                      Depends: libgamin0 but it is not going to be installed
                      Depends: libhunspell-1.4-0 but it is not installable
                      Recommends: valgrind but it is not going to be installed
                      Recommends: cppcheck but it is not going to be installed
                      Recommends: cscope but it is not going to be installed
                      Recommends: cccc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12321
    • Travis build status
Re: ubuntu : "wxSmith plugin is not loaded, can not continue"
« Reply #3 on: March 01, 2020, 03:06:10 pm »
Pass all debs on the command line. I would also make a single package if it were to me, but this is not how debian is supposed to work. There you're supposed to split stuff in smaller packages, I think, I guess I could research this...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline cacb

  • Regular
  • ***
  • Posts: 424
Re: ubuntu : "wxSmith plugin is not loaded, can not continue"
« Reply #4 on: March 01, 2020, 03:37:30 pm »
Which package? There are a so many different packages. A monolithic install would make things simpler for new-comers.

You could try this

sudo dpkg -i *.deb

Offline paddle

  • Single posting newcomer
  • *
  • Posts: 8
Re: ubuntu : "wxSmith plugin is not loaded, can not continue"
« Reply #5 on: March 01, 2020, 03:52:39 pm »
The contrib deb does not want to install apparantly.
sudo dpkg -i *.deb give the following :
Code: [Select]
sudo dpkg -i *.deb

(Reading database ... 278344 files and directories currently installed.)
Preparing to unpack codeblocks_17.12-1_amd64.deb ...
Unpacking codeblocks (17.12-1) over (17.12-1) ...
Preparing to unpack codeblocks-common_17.12-1_all.deb ...
Unpacking codeblocks-common (17.12-1) over (17.12-1) ...
Selecting previously unselected package codeblocks-contrib.
Preparing to unpack codeblocks-contrib_17.12-1_amd64.deb ...
Unpacking codeblocks-contrib (17.12-1) ...
Preparing to unpack codeblocks-contrib-common_17.12-1_all.deb ...
Unpacking codeblocks-contrib-common (17.12-1) over (17.12-1) ...
Preparing to unpack codeblocks-dev_17.12-1_amd64.deb ...
Unpacking codeblocks-dev (17.12-1) over (17.12-1) ...
Preparing to unpack codeblocks-headers_17.12-1_all.deb ...
Unpacking codeblocks-headers (17.12-1) over (17.12-1) ...
Preparing to unpack codeblocks-libwxcontrib0_17.12-1_amd64.deb ...
Unpacking codeblocks-libwxcontrib0 (17.12-1) over (17.12-1) ...
Preparing to unpack codeblocks-wxcontrib-dev_17.12-1_amd64.deb ...
Unpacking codeblocks-wxcontrib-dev (17.12-1) over (17.12-1) ...
Preparing to unpack codeblocks-wxcontrib-headers_17.12-1_all.deb ...
Unpacking codeblocks-wxcontrib-headers (17.12-1) over (17.12-1) ...
Preparing to unpack libcodeblocks0_17.12-1_amd64.deb ...
Unpacking libcodeblocks0 (17.12-1) over (17.12-1) ...
Preparing to unpack libwxsmithlib0_17.12-1_amd64.deb ...
Unpacking libwxsmithlib0 (17.12-1) over (17.12-1) ...
Preparing to unpack libwxsmithlib0-dev_17.12-1_amd64.deb ...
Unpacking libwxsmithlib0-dev (17.12-1) over (17.12-1) ...
Preparing to unpack wxsmith-dev_17.12-1_amd64.deb ...
Unpacking wxsmith-dev (17.12-1) over (17.12-1) ...
Preparing to unpack wxsmith-headers_17.12-1_all.deb ...
Unpacking wxsmith-headers (17.12-1) over (17.12-1) ...
Setting up codeblocks-common (17.12-1) ...
dpkg: dependency problems prevent configuration of codeblocks-contrib:
 codeblocks-contrib depends on libboost-system1.62.0; however:
  Package libboost-system1.62.0 is not installed.
 codeblocks-contrib depends on libgamin0; however:
  Package libgamin0 is not installed.
 codeblocks-contrib depends on libhunspell-1.4-0; however:
  Package libhunspell-1.4-0 is not installed.

dpkg: error processing package codeblocks-contrib (--install):
 dependency problems - leaving unconfigured
Setting up codeblocks-contrib-common (17.12-1) ...
Setting up codeblocks-headers (17.12-1) ...
Setting up codeblocks-libwxcontrib0 (17.12-1) ...
Setting up libcodeblocks0 (17.12-1) ...
Setting up libwxsmithlib0 (17.12-1) ...
Setting up wxsmith-headers (17.12-1) ...
Setting up codeblocks (17.12-1) ...
Setting up codeblocks-dev (17.12-1) ...
Setting up wxsmith-dev (17.12-1) ...
Setting up libwxsmithlib0-dev (17.12-1) ...
Setting up codeblocks-wxcontrib-dev (17.12-1) ...
Setting up codeblocks-wxcontrib-headers (17.12-1) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu1) ...
Processing triggers for mime-support (3.63ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for man-db (2.8.7-3) ...
Processing triggers for shared-mime-info (1.10-1) ...
Processing triggers for libc-bin (2.30-0ubuntu2.1) ...
Errors were encountered while processing:
 codeblocks-contrib

Any idea why?

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2600
Re: ubuntu : "wxSmith plugin is not loaded, can not continue"
« Reply #6 on: March 01, 2020, 04:16:29 pm »
Code: [Select]
odeblocks-contrib depends on libboost-system1.62.0; however:
  Package libboost-system1.62.0 is not installed.
 codeblocks-contrib depends on libgamin0; however:
  Package libgamin0 is not installed.
 codeblocks-contrib depends on libhunspell-1.4-0; however:
  Package libhunspell-1.4-0 is not installed.
install libboost-system and libgamin and libhunspell

Offline paddle

  • Single posting newcomer
  • *
  • Posts: 8
Re: ubuntu : "wxSmith plugin is not loaded, can not continue"
« Reply #7 on: March 04, 2020, 07:31:06 am »
install libboost-system and libgamin and libhunspell
Tried this without much luck.
libboost-system is already installed but version 1.67 not 1.62.
libgamin solved itself by typing "apt --fix-broken install"
libhunspell is also already installed.
Quote
libhunspell-1.7-0/eoan,now 1.7.0-2build1 amd64 [installed,automatic]
libhunspell-1.7-0/eoan 1.7.0-2build1 i386
libhunspell-dev/eoan 1.7.0-2build1 amd64
libhunspell-dev/eoan 1.7.0-2build1 i386

So it seems the packages are expecting older version of the libraries. What should I do?

I chose Ubuntu thinking, as it's mainstream everything will be working out of the boxe. Though it's clearly not true apparantly.
« Last Edit: March 04, 2020, 07:38:14 am by paddle »