Author Topic: How to compile CodeBlocks with wxWidgets 3.1.3  (Read 139 times)

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2192
How to compile CodeBlocks with wxWidgets 3.1.3
« on: February 06, 2020, 08:10:29 pm »
How do you compile wxWidgets 3.1.3 and CodeBlocks source for Linux.

On Linux Mint 19.2 I have compiled wxWidgets 3.1.3 with the following script.
./configure --prefix=/opt/wx/3.1.3 \
       --enable-xrc \
       --enable-monolithic \
       --enable-shared \
       --enable-unicode

How do I now compile CodeBlocks source with the the resulting wxWidgets?
« Last Edit: February 06, 2020, 09:30:07 pm by Pecan »

Offline sodev

  • Regular
  • ***
  • Posts: 353
Re: How to compile CodeBlocks with wxWidgets 3.1.3
« Reply #1 on: February 06, 2020, 09:50:21 pm »
I don't know if CodeBlocks can use the monolithic library out-of-the-box or how to make it use it, so far i was always using the individual libraries because that is how the systems i used provided wxWidgets, but basically you have to supply the path of the wx-config script to the configure script of CodeBlocks. With your setup this would be something like this:

Code: [Select]
./configure --with-wx-config=/opt/wx/3.1.3/bin/wx-config