Author Topic: ubuntu nightly build [solved]  (Read 706 times)

Offline ccdric

  • Single posting newcomer
  • *
  • Posts: 9
ubuntu nightly build [solved]
« on: December 30, 2019, 05:01:58 pm »
my last build was 11736 on ubuntu disco.

I tried to update to laste rev on svn :
My way to build  :
in ~/installManuel/codeblocks directory

# get last rev
svn update ./trunk
svn up -r 11927

cd trunk
dpkg-buildpackage -us -uc

cd ..
sudo dpkg -i *.deb
build ran ok with gtk3-unicode-3.1-unofficial3 (same I used for previous rev)
Code: [Select]
[email protected]:$ wx-config --libs
-L/usr/lib/x86_64-linux-gnu -pthread   -lwx_gtk3u_unofficial3_xrc-3.1 -lwx_gtk3u_unofficial3_html-3.1 -lwx_gtk3u_unofficial3_qa-3.1 -lwx_gtk3u_unofficial3_core-3.1 -lwx_baseu_unofficial3_xml-3.1 -lwx_baseu_unofficial3_net-3.1 -lwx_baseu_unofficial3-3.1

but launching codeblock crash after about 3'30" like this : 
Code: [Select]
Starting Code::Blocks svn build  rev 11927 Dec 30 2019, 13:35:24 - wx3.1.2 - gcc 8.3.0 (Linux, unicode) - 64 bit
Manager initialized
Initialize EditColourSet .....
Initialize EditColourSet: done.
Loading menubar...
Profiler: loaded
CodeStat: loaded
RegExTestbed: loaded
CodeCompletion: loaded
wxSmithAui: loaded
SmartIndentFortran: loaded
ToolsPlus: loaded
SmartIndentXML: loaded
FilesExtensionHandler: loaded
SmartIndentPython: loaded
BYOGames: loaded
SmartIndentLua: loaded
CppCheck: loaded
SpellChecker: loaded
MouseSap: loaded
HexEditor: loaded
NassiShneidermanPlugin: loaded
Exporter: loaded
ClassWizard: loaded
HelpPlugin: loaded
ToDoList: loaded
Abbreviations: loaded
FileManager: loaded
Compiler: loaded
ReopenEditor: loaded
OccurrencesHighlighting: loaded
wxSmithContribItems: loaded
cbKeyBinder: loaded
HeaderFixup: loaded
Cccc: loaded
EnvVars: loaded
AutoVersioning: loaded
AStylePlugin: loaded
Valgrind: loaded
wxSmith: loaded
wxSmithMime: loaded
CB_Koders: loaded
lib_finder: loaded
ProjectOptionsManipulator: loaded
Autosave: loaded
IncrementalSearch: loaded
SmartIndentCpp: loaded
SmartIndentHDL: loaded
SmartIndentPascal: loaded
BrowseTracker: loaded
SymTab: loaded
DoxyBlocks: loaded
EditorTweaks: loaded
cbDragScroll: loaded
CodeSnippets: loaded
ScriptedWizard: loaded
Debugger: loaded
ProjectsImporter: loaded
ThreadSearch: loaded
copystrings: loaded
EditorConfig: loaded
Cscope: loaded
OpenFilesList: loaded
Code profiler plugin activated
Code statistics plugin activated
Regular expressions testbed plugin activated
Code completion plugin activated
wxSmith - Aui plugin activated
SmartIndentFortran plugin activated
ToolsPlus plugin activated
SmartIndentXML plugin activated
Files extension handler plugin activated
SmartIndentPython plugin activated
BYO Games plugin activated
SmartIndentLua plugin activated
CppCheck plugin activated
Detected dict path: /usr/share/hunspell
Detected thes path: /usr/share/mythes
Found dictionary: fr_MC
Found dictionary: fr_FR
Found dictionary: en_GB
Found dictionary: fr_CH
Found dictionary: fr_CA
Selected dictionary: en_US
Found dictionary: en_US
Found dictionary: fr_BE
Found dictionary: en_AU
Found dictionary: fr
Found dictionary: fr_LU
Found dictionary: en_ZA
Loading image: '/usr/share/codeblocks/SpellChecker/16x16/en_US.png' succeeded!
SpellChecker plugin activated
MouseSap plugin activated
HexEditor plugin activated
NassiShneidermanPlugin plugin activated
Source Exporter plugin activated
Class wizard plugin activated
Help plugin plugin activated
Todo List plugin activated
Abbreviations plugin activated
FileManager plugin activated
Added compiler "GNU GCC Compiler"
Added compiler "Intel C/C++ Compiler"
Added compiler "GDC D Compiler"
Added compiler "GNU Fortran Compiler"
Added compiler "G95 Fortran Compiler"
Added compiler "GNU GCC Compiler for ARM"
Added compiler "Small Device C Compiler"
Added compiler "GNU GCC Compiler for PowerPC (HighTec)"
Added compiler "Digital Mars D Compiler"
Added compiler "GNU GCC Compiler for ZPU"
Added compiler "GNU GCC Compiler for TriCore (HighTec)"
Added compiler "LLVM Clang Compiler"
../src/common/wincmn.cpp(477): assert "GetEventHandler() == this" failed in ~wxWindowBase(): any pushed event handlers must have been removed
Trappe pour point d'arrêt et de trace (core dumped)

cpu a memory (16Go) consomption is huge during startup :
top - 16:28:01 up 3 min,  1 user,  load average: 1,52, 1,08, 0,47
Tâches: 276 total,   2 en cours, 274 en veille,   0 arrêté,   0 zombie
%Cpu(s): 12,6 ut,  0,2 sy,  0,0 ni, 87,2 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st
MiB Mem :  15966,2 total,   6094,6 libr,   7491,1 util,   2380,5 tamp/cache
MiB Éch:   4023,0 total,   4023,0 libr,      0,0 util.   7676,6 dispo Mem

  PID UTIL.     PR  NI    VIRT    RES    SHR S  %CPU  %MEM    TEMPS+ COM.       
 6213 cedric    20   0 7116520   6,1g  68432 R  99,7  39,1   3:01.49 codeblocks
 5610 cedric    20   0 3311492 363216 199476 S   0,7   2,2   0:22.36 gnome-she+

I tried to remove ~/.config/codeblock directory and reboot, but it crash the same way

anybody can help me ?
« Last Edit: January 02, 2020, 03:41:35 pm by ccdric »

Offline gd_on

  • Lives here!
  • ****
  • Posts: 570
Re: nightly 11927
« Reply #1 on: December 30, 2019, 07:33:50 pm »
I don't know if it is the problem, but I see you use wx 3.1.2. C::B had problems with this version, at least on Windows (I don't know on Linux). Are you able to find a wx 3.1.3 version ?
You can also try the ready-to-use version for debian/ubuntu provided by xaviou (see link in the post for nightly versions). It works with wx 3.0.4 I think, not the last one, but not too old !

Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline ccdric

  • Single posting newcomer
  • *
  • Posts: 9
Re: nightly 11927
« Reply #2 on: December 31, 2019, 09:54:43 am »
thanks gd_on
using wxidget 3.04 make it run perfectly ....

if somebody else  need it :
juste run  :
sudo update-alternatives --config wx-config
[sudo] Mot de passe de cedric :
Il existe 7 choix pour l'alternative wx-config (qui fournit /usr/bin/wx-config).

  Sélection   Chemin                                                            Priorité  État
  0            /usr/lib/x86_64-linux-gnu/wx/config/gtk2-unicode-3.1-unofficial    318       mode automatique
  1            /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-3.0               306       mode manuel
  2            /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-3.1-unofficial    317       mode manuel
  3            /usr/lib/x86_64-linux-gnu/wx/config/base-unicode-3.1-unofficial3   317       mode manuel
  4            /usr/lib/x86_64-linux-gnu/wx/config/gtk2-unicode-3.0               308       mode manuel
  5            /usr/lib/x86_64-linux-gnu/wx/config/gtk2-unicode-3.1-unofficial    318       mode manuel
* 6            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.0               307       mode manuel
  7            /usr/lib/x86_64-linux-gnu/wx/config/gtk3-unicode-3.1-unofficial3   318       mode manuel

Appuyez sur <Entrée> pour conserver la valeur par défaut
  • ou choisissez le numéro sélectionné :
select 6 for me
then rebuild and install .deb
dpkg-buildpackage -us -uc

# instalation
cd ..
dpkg -i *.deb