Author Topic: Handle different builds of wxWidgets  (Read 129 times)

Offline seahawkibiza

  • Multiple posting newcomer
  • *
  • Posts: 19
Handle different builds of wxWidgets
« on: November 27, 2019, 04:10:04 pm »
Hello,
as C::B uses also wxWidgets I run in a serious problem.
On debian64 I installed a fresh version of C::B. It uses wxWidgets 3.0.2.

Our application what I write/build with C::B uses also wxWidgets - the same stable release 3.0.2.
But I compiled wxWidgets with different modules, unicode, etc... as release and also debug version.
I installed they in /opt/wxdeb, /opt/wxrel and use the correspondig flags for the compiler/linker. (wx-config --cflags)

But the problem is: If I want debug/run my project I need the libs in the search path - but my version.
If I use only my version C::B canīt start, because the wanted wxWidgets libs (with the same names) are not correct build for usage with C::B.
If I use the libs, they comes with CodeBlocks (in usr/libs/x86.../) my program faults...

So - how can I handle this? With an older version of C::B, what was using 2.9.x of wxWidgets was not a problem, due the different names of the libs.
« Last Edit: November 27, 2019, 04:14:46 pm by seahawkibiza »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12129
    • Travis build status
Re: Handle different builds of wxWidgets
« Reply #1 on: November 30, 2019, 09:57:59 am »
This shouldn't be a problem because C::B can modify the LD_LIBRARY_PATH before run/debugging your application. Are you sure you've not disabled this feature? See Project -> Properties -> Debugger -> Do NOT adjust LD_LIBRARY_PATH
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]