Author Topic: [SOLVED] Floating Point Error  (Read 188 times)

Offline dcbdbis

  • Multiple posting newcomer
  • *
  • Posts: 21
[SOLVED] Floating Point Error
« on: October 29, 2019, 09:21:31 pm »
I don't know if this is a codeblocks issue or a wxWidgets issue.

Previous builds work just fine (wxWidgets 3.0.4). I have two identical systems. One that is not networked for military projects, and another that is. They are both on Arch Linux, CB 17:12, with both OS's at the same service levels.

On my main workstation(networked) I downloaded and built wxWidgets 3.1.3 today, and installed it to /usr/local. ld.so.conf was updated. On the networked workstation - I had no issues porting an app from wxWidgets 3.0.4 to 3.1.3. Obviously the wxflags had to be modified to point to the newer install. The app built and ran fine in both release and debug builds.

I repeated my steps for the air-gapped workstation. Including going through the project build options to ensure that I had changed EVERYTHING to point to the new wx-config, the new includes, removing the old link libraries and linking in the new libs (static but not monolithic), etc.

On the "air-gapped" workstation (which requires manual copying of updates and files via a USB HDD)....The application builds fine, yet I get the attached error when I try to debug.

No such issues on the networked workstation.

I have been through the build options a dozen times to ensure that everything has been modified - and the CB setup of the two workstations is identical, both in the global compiler settings, and in the project build options. Both build, one runs, the other doesn't.

The issue is the wx 3.0 file referenced in the below screencap has me puzzled. Is this coming from CB or wxWidgets? Do I need to rebuild CB against wx 3.1.3? I will if I need to. I can find no reference to this wx 3.0 lib at all in the project options, nor the global compiler settings, nor the linker.

I have no idea where to look next.

Pointers and assistance will be very much appreciated.


Sincerely and respectfully,

Dave

Edit:  I did a clean build of wx3.1.3 on each workstation. No copying a already built wx library from one machine to another. And the exact same configure options too.

Edit #2: configure options: --disable-shared --with-gtk=3
« Last Edit: October 30, 2019, 12:03:37 am by dcbdbis »

Offline dcbdbis

  • Multiple posting newcomer
  • *
  • Posts: 21
Re: [SOLVED] Floating Point Error
« Reply #1 on: October 30, 2019, 12:05:56 am »
It was my wxWidgets build.

I built it all as a static library in anticipation of doing a static link.....I "make uninstall"'d it, cleaned it, and rebuilt it as a shared library. Both systems are operating normally, and the default "About" reports in as wxWidgets 3.1.3 as it should.

I have no answers as to why....I can only tell you what I did - and that it works now....


Dave