Author Topic: Problem with Code::Blocks  (Read 1078 times)

Offline MannyMoe

  • Multiple posting newcomer
  • *
  • Posts: 14
Problem with Code::Blocks
« on: July 30, 2019, 10:25:18 pm »
Hello:
 I am using Code::Blocks 16.01 and Lubuntu 18.04. When I compile and link a file
the executable is NOT written to disk. It works fine in Code::Blocks. When I go to
the disk there is a question mark on the file. When I click on the file it wants to know
what I want to use to open the file. Can anyone help me with this?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12086
    • Travis build status
Re: Problem with Code::Blocks
« Reply #1 on: July 30, 2019, 11:10:14 pm »
What are the permissions of the file? Is it executable?
Use a file manager or the ls -l command to find out.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline MannyMoe

  • Multiple posting newcomer
  • *
  • Posts: 14
Re: Problem with Code::Blocks
« Reply #2 on: July 31, 2019, 01:03:27 am »
File is set to anyone.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6666
    • My Best Post
Re: Problem with Code::Blocks
« Reply #3 on: July 31, 2019, 02:09:51 am »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline MannyMoe

  • Multiple posting newcomer
  • *
  • Posts: 14
Re: Problem with Code::Blocks
« Reply #4 on: August 01, 2019, 09:00:44 pm »
Yes it is.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12086
    • Travis build status
Re: Problem with Code::Blocks
« Reply #5 on: August 01, 2019, 10:36:16 pm »
Then you should ask the provider of your file manager why it behaves like it behaves.

Modern linuxes depend on .desktop files, so it might be related to this.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline MannyMoe

  • Multiple posting newcomer
  • *
  • Posts: 14
Re: Problem with Code::Blocks
« Reply #6 on: August 07, 2019, 10:36:54 pm »
This was my first experience with using 64 bit.
I guess I will go back to a 32 bit machine!
It seems things work better! Thanks!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12086
    • Travis build status
Re: Problem with Code::Blocks
« Reply #7 on: August 07, 2019, 11:27:08 pm »
There isn't much difference on linux. Also 32bit machines are almost dead!
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jacksmith

  • Single posting newcomer
  • *
  • Posts: 6
Re: Problem with Code::Blocks
« Reply #8 on: October 07, 2019, 01:36:17 pm »
I'm new in codeblocks. I've installed codeblocks-17.12mingw but there's a problem when I open codeblock it shows a error bellow

Environment error

Can't find compiler executable in your configured search path's  for Microsoft Visual C++ Toolkit 2003.   
Please see the attachment.
Thanks

Note: I'm using windows 10 64 bit

Offline sodev

  • Regular
  • ***
  • Posts: 329
Re: Problem with Code::Blocks
« Reply #9 on: October 07, 2019, 01:37:57 pm »
Crossposting/Crossspamming your very same question into multiple unrelated threads will help you much to get removed from this forum very quickly.