Author Topic: Crash with batch build on linux  (Read 4319 times)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12067
    • Travis build status
Re: Crash with batch build on linux
« Reply #45 on: September 14, 2019, 01:28:53 am »
Here is the windows part. Thank you for showing me the error of the flags. I tried also to add some documentation and why we use this timer function...
Does this polling work fine on linux? Does it add overhead? I don't like default values for parameters.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2545
Re: Crash with batch build on linux
« Reply #46 on: September 19, 2019, 11:08:29 am »
Sry i expressed me wrong... The "poll" is only sending an idle event. And this also only every second (I think we could increase the time even more. But then in the worst case the stall on windows would last for this long). I build codeblocks with this patch several times and never had any problems or slowdowns on my build server.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2545
Re: Crash with batch build on linux
« Reply #47 on: September 26, 2019, 08:26:45 am »
There are other parts of the code that slow down the build process unnecessary A LOT (i am looking at you CompilerCommandGenerator )...
What is wrong about the default parameter? In general or the selected values?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12067
    • Travis build status
Re: Crash with batch build on linux
« Reply #48 on: September 26, 2019, 08:42:07 am »
In general.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]