Author Topic: Code::Blocks bug, atleast for me it is and some folks ;)  (Read 213 times)

Offline Uwohm9

  • Single posting newcomer
  • *
  • Posts: 1
Code::Blocks bug, atleast for me it is and some folks ;)
« on: August 23, 2019, 06:21:09 pm »
I just want to report a bug.
I don't know if this comes to the right place, but since I didn't have been to any programming/IDE/computing forum for the last 4 years I will just place it here.

It's about an option in Settings -> Environment settings -> General Settings.
In this window there is an option(checkbox) called "Allow only one running instance", I prefer to disable it since I work on multiple projects at the same time.

Some background info:
I bought a new PC so I had to reinstall Code::Blocks.
If you open Code::Blocks for the first time when installed, a window will appear asking you to associate C++ files on your computer to open with Code::Blocks.
I remembered I did not on my old PC, but you know since I use Code::Blocks a lot, I was like, okay why not.
After checking the option "Associate C++ files with Code::Blocks", I noticed when the option "Allow only one running instance"[disabled] in combination with "Use an already running instance"[disabled] doesn't work anymore, it will always open new projects in an existing Code::Blocks window if double click on a .CBP file. If you first run Code::Blocks when there is already one opened, and from the new Code::Blocks window you open a project, there is no problem. But since I have to open 4 different projects, I just double click the projects (.CBP files) because it's much faster then open a new Code::Blocks window and from there look for your project files.

So straight to the point:
- If at the beginning from a fresh install you chose "Associate C++ files with Code::Blocks" double click doesn't work with "Allow only one running instance"[disabled] in combination with "Use an already running instance"[disabled].
- If you chose "Not to associate C++ files with Code::Blocks" double click does work with "Allow only one running instance"[disabled] in combination with "Use an already running instance"[disabled].

I hope I provided enough information to fix this bug.
Just a thought, maybe an extra option(checkbox) with this double click related problem will be nice, if the above description isn't a problem but a developer way of thinking it will be still nice to add this checkbox ;)

Thanks in advance.
« Last Edit: August 23, 2019, 06:28:16 pm by Uwohm9 »

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2464
Re: Code::Blocks bug, atleast for me it is and some folks ;)
« Reply #1 on: August 24, 2019, 04:55:27 pm »
Made a ticket, because here it will get lost...
https://sourceforge.net/p/codeblocks/tickets/865/