Author Topic: The 13 february 2006 build is out.  (Read 18755 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
The 13 february 2006 build is out.
« on: February 13, 2006, 11:35:54 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml
A link to the unicode windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26u_gcc_cb.7z
For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://download.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26_gcc_cb.7z

The 13 February 2006 build is out.
  - Windows : http://download.berlios.de/codeblocks/CB_20060213_rev2001_win32.7z
  - Linux : not supported yet


Resolved Fixed:

  • Script bindings updates
  • Support double-click editing in project dependencies
  • Changed CB_IMPLEMENT_PLUGIN macro and friends, to take an additional argument as the plugin's title. This will fix the "disabled plugins are displayed by name instead of title" problem in "Plugins->Manage plugins". Updated all plugins (core and contrib)
  • Added GetDefaultPath() and SetDefaultPath() in ProjectManager. These return/set the default path for new projects
  • BcbEVT_TARGETS_MODIFIED is now fired when targets are modified in any way. This fixes the bug with the out-of-sync targets toolbar combobox
  • Fixed MacrosManager to recognize the targets toolbar combobox. This means that macros that rely on the selected target work now even if not building the project
  • Small fix in script bindings
  • Added random compiler variables
  • Patch #827 : Unicode fixes
  • Added "Clear Libraries" button (patch by Morten McFly)
  • cbMessageBox (drop-in replacement for wxMessageBox)
  • TODO plugin remembers style and position selection
  • Adjusted spacing of buttons from rev 1998

Regressions/Confirmed/Annoying/Common bugs:

  • DDE bug : clicking in windows explorer on a CB registered file throws an error message box
  • toolbar-images-not-changing-state (is a wx problem)


Offline Acki

  • Multiple posting newcomer
  • *
  • Posts: 100
Re: The 13 february 2006 build is out.
« Reply #1 on: February 14, 2006, 02:51:36 am »
Hi,
I think there is a little bug now...
I can't delete tools from the tools menu anymore !!!

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: The 13 february 2006 build is out.
« Reply #2 on: February 14, 2006, 08:28:40 am »
custom variables can't be deleted either ...

Offline Szabadember

  • Multiple posting newcomer
  • *
  • Posts: 75
  • That's me!
Re: The 13 february 2006 build is out.
« Reply #3 on: February 14, 2006, 11:31:50 am »
Quote
DDE bug : clicking in windows explorer on a CB registered file throws an error message box

This bug is not present anymore for me!(for about i don't know how much builds now)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
Re: The 13 february 2006 build is out.
« Reply #4 on: February 14, 2006, 11:41:53 am »
it seems to be gone, but I had it happening on me, last week (once).

Offline artur

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 13 february 2006 build is out.
« Reply #5 on: February 14, 2006, 12:35:21 pm »
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: The 13 february 2006 build is out.
« Reply #6 on: February 14, 2006, 12:45:17 pm »
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
Re: The 13 february 2006 build is out.
« Reply #7 on: February 14, 2006, 03:24:59 pm »
Quote
I can't delete tools from the tools menu anymore !!!

Quote
custom variables can't be deleted either ...

Yiannis has fixed those in rev 2002

Offline Szabadember

  • Multiple posting newcomer
  • *
  • Posts: 75
  • That's me!
Re: The 13 february 2006 build is out.
« Reply #8 on: February 14, 2006, 04:05:34 pm »
When will be Code::Blocks RC3 out?
Are there any more serious bugs, that need to be fixed?

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: The 13 february 2006 build is out.
« Reply #9 on: February 14, 2006, 04:42:26 pm »
When will be Code::Blocks RC3 out?
When it's ready.  (Trademark owned by mandrav).

Are there any more serious bugs, that need to be fixed?
Yes, several bugs as well as a few things that are still rather suboptimal.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Acki

  • Multiple posting newcomer
  • *
  • Posts: 100
Re: The 13 february 2006 build is out.
« Reply #10 on: February 14, 2006, 08:15:50 pm »
custom variables can't be deleted either ...

But I could before this version !!!
I recopied the old version, deleted the tools and copie the new version again over it !!!
But if I trie this with the new version I can't !?!?!
I go to the customize tools menu, select a tool, click on "remove", I get asked if I really whant to, I select yes but the entry is still there !!!!!

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
Re: The 13 february 2006 build is out.
« Reply #11 on: February 14, 2006, 08:18:25 pm »
This was a bug introduced yesterday, tonight nightly (which is building at this very moment) will have it fixed :-)

Offline Zingam

  • Multiple posting newcomer
  • *
  • Posts: 74
Re: The 13 february 2006 build is out.
« Reply #12 on: February 14, 2006, 09:23:40 pm »
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->

Something doesn't work here. First before I chose UTF-8 an empty file was saved overwritting everyting. After that I've chosen UTF-8 but after saving CB the characters were not the right one. I was trying to use cyrillic characters.

Is it possible for CB to automatically detect the encoding, when using non-ASCII characters?

Should I report this as a bug or as suggestion for a new feature?

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: The 13 february 2006 build is out.
« Reply #13 on: February 14, 2006, 10:00:32 pm »
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->

Something doesn't work here. First before I chose UTF-8 an empty file was saved overwritting everyting. After that I've chosen UTF-8 but after saving CB the characters were not the right one. I was trying to use cyrillic characters.

Is it possible for CB to automatically detect the encoding, when using non-ASCII characters?

Should I report this as a bug or as suggestion for a new feature?

i also had 0-byte files when saving as ISO-encoded file, but it worked for me after switching to UTF-8, but i don't use cyrillic chars  :roll:

Offline Game_Ender

  • Lives here!
  • ****
  • Posts: 551
Re: The 13 february 2006 build is out.
« Reply #14 on: February 14, 2006, 10:51:10 pm »
Yes, several bugs as well as a few things that are still rather suboptimal.

Is there any time to setup a roadmap kind of like what Ogre has.  I am sure you or Mandrav, already has one in there head, this just gives the community a little more insight into the fast developement cycle codeblocks has.
« Last Edit: February 15, 2006, 08:32:14 am by Game_Ender »

Offline artur

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 13 february 2006 build is out.
« Reply #15 on: February 15, 2006, 07:38:47 am »
When I use Polish characters in source code
       wxMessageBox(_("Błąd podczas pobierania listy baz"), _("BŁĄD"), wxICON_ERROR | wxOK);
CB writes on HDD empty file.
When I delete these characters file is written OK.

use UTF-8 encoding

Edit->File Encoding->

Something doesn't work here. First before I chose UTF-8 an empty file was saved overwritting everyting. After that I've chosen UTF-8 but after saving CB the characters were not the right one. I was trying to use cyrillic characters.

Is it possible for CB to automatically detect the encoding, when using non-ASCII characters?

Should I report this as a bug or as suggestion for a new feature?

i also had 0-byte files when saving as ISO-encoded file, but it worked for me after switching to UTF-8, but i don't use cyrillic chars  :roll:

I've switched encoding to UTF-8 and then files were seved correctly, but...
When I've closed file and reopened it (without closing CB) encoding was set to ASCII again.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 13 february 2006 build is out.
« Reply #16 on: February 15, 2006, 08:35:39 am »
If you 're having problems, please start a new topic. This forum is only for nightlies announcements.

C::B doesn't perform encoding detection (yet). If someone wants to implement it, patches are welcome.
Here's a link to help you get started: A composite approach to language/encoding detection
Be patient!
This bug will be fixed soon...

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: The 13 february 2006 build is out.
« Reply #17 on: February 15, 2006, 09:14:58 am »
If you saved as UTF-8, just make sure to save it with the BOM.

Offline Antrykot

  • Single posting newcomer
  • *
  • Posts: 3
Re: The 13 february 2006 build is out.
« Reply #18 on: February 15, 2006, 09:56:57 am »
Hi,
When I remove some files from project (about 3 or 4) the CB crashes (on Windows XP) :/
Can you fix this ? :)

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: The 13 february 2006 build is out.
« Reply #19 on: February 15, 2006, 11:40:22 am »
Is there any time to setup a roadmap kind of like what Ogre has.

Ogre annotated roadmap looks good, clear and easy to read.

Michael