Author Topic: RFC: Dropping support for old wxWidgets releases (2.8 in particular)  (Read 3884 times)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #30 on: April 04, 2020, 09:56:30 pm »
The ball is rolling https://github.com/obfuscated/codeblocks_sf/commits/experiments/wx-cleanup
The removal of support for wx28 would be committed sometime next week. I'm testing linux and macOS. No time to check if windows is working, so I'll need help if you want the builds to be working for sure on windows.

Removal plans include:
1. remove all wx28 projects
2. remove all wx30 projects on windows (32 and 64 bit)
3. remove wxpropgrid we use in wx28
4. remove wxTreeList we ship in wx28
5. fix autotools build
6. make it an error if using older versions of wx.

After this is committed to trunk there are two more steps:
step2: remove all conditionals for wx2.8/2.9
step3: remove all wxT uses

Reporting problems now is better then after I commit. :)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6894
    • My Best Post
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #31 on: April 04, 2020, 10:19:02 pm »
Would it be possible to remove all the 2.8/2.6 wxWidgets template files at this time.

Under these paths

src/templates/common
src/templates/unix
src/templates/win32

Tim S.


C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #32 on: April 04, 2020, 11:18:58 pm »
It was not in my plans. Someone would have to contribute these. Especially the changes to the windows' templates.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #33 on: April 07, 2020, 08:15:38 pm »
Any feedback on the windows builds? Is everything working?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Online BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2709
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #34 on: April 08, 2020, 09:36:29 am »
Looks good to me

Offline Hyena

  • Multiple posting newcomer
  • *
  • Posts: 21
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #35 on: April 10, 2020, 11:12:53 am »
I had a crash yesterday with the 20.03 running on Linux Mint. I didn't lose any important work because I save often :D. Unfortunately there was no error message or anything specific about the crash. I was just starting to define a new struct in one header file and it crashed. Could not reproduce.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #36 on: April 10, 2020, 06:59:26 pm »
Great report... in the correct topic... thank you  8)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #37 on: April 17, 2020, 05:00:32 pm »
wx28 support is removed from trunk/master. The code would build if you restore the project files and remove the protections, but this would soon change...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Miguel Gimenez

  • Regular
  • ***
  • Posts: 436
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #38 on: April 17, 2020, 05:50:45 pm »
Should batch_build_all_30.bat and the like be removed too?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6894
    • My Best Post
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #39 on: April 17, 2020, 05:54:11 pm »
Did not know that you were changing prep.h to require wxWidgets 3.1.3 or higher under windows?

This was on purpose, correct?

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12595
    • Travis build status
Re: RFC: Dropping support for old wxWidgets releases (2.8 in particular)
« Reply #40 on: April 17, 2020, 05:57:36 pm »
@Miguel: Yes, they have to be removed. I'll do so soon.

@stahta01: Of course. You could remove it, but don't expect to get any kind of support. :)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]