Author Topic: Opensuse-Leap-42.3 :: lost compiler flags  (Read 659 times)

Offline LETARTARE

  • Regular
  • ***
  • Posts: 403
  • L'ami de l'homme.The friend of man.
Opensuse-Leap-42.3 :: lost compiler flags
« on: July 23, 2019, 07:05:00 pm »
I use :
Quote
wx-config --version
2.8.12       
       
and                                                                       
Quote
gcc --version
gcc (SUSE Linux) 4.8.5

I am now using only 'CB' versions compiled in  "/home/name/SVN_COMPILE/Cb/..."

 When compiling 'Code::Blocks wx2.8.x (Unix)-11800'  and reading the compiler flags  'Gcc' by 
Quote
'Project->Build Options->Project->Compiler Flags'
: the window is empty !
All other compiled versions of CB are in the same case.

I searched in "/home/name/.config/codeblocks/...",  but no "compilers/options_gcc.xml" file that I thought could erase.

Could you tell me the solution to this problem ?


CB-rev12091, plugins : QtPregen-2.7.3-sdk220
1-Win 7 Business Pack 1 64bits :  wx-3.1.3, gcc-8.1.0,
2-OpenSuse-15.1-Leap 64bits : wx-3.03, gcc-7.5.
=> !! The messages are translated by Deepl !!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12600
    • Travis build status
Re: Opensuse-Leap-42.3 :: lost compiler flags
« Reply #1 on: July 23, 2019, 08:13:06 pm »
Do you have any xml file related to the compiler options in your install folder? Do you have cb in system folder?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline osdt

  • Multiple posting newcomer
  • *
  • Posts: 61
Re: Opensuse-Leap-42.3 :: lost compiler flags
« Reply #2 on: July 23, 2019, 09:36:48 pm »
...
I searched in "/home/name/.config/codeblocks/...",  but no "compilers/options_gcc.xml" file that I thought could erase.

Have a look at $HOME/.local/share/codeblocks/compilers .

Offline LETARTARE

  • Regular
  • ***
  • Posts: 403
  • L'ami de l'homme.The friend of man.
Re: Opensuse-Leap-42.3 :: lost compiler flags
« Reply #3 on: July 23, 2019, 11:30:50 pm »
Thanks for the answers

@osdt :
Won: it's actually at that location!
Removing it solves the problem.
CB-rev12091, plugins : QtPregen-2.7.3-sdk220
1-Win 7 Business Pack 1 64bits :  wx-3.1.3, gcc-8.1.0,
2-OpenSuse-15.1-Leap 64bits : wx-3.03, gcc-7.5.
=> !! The messages are translated by Deepl !!