Author Topic: CB not saving Project Linker Settings  (Read 361 times)

Offline BobsTheDude

  • Single posting newcomer
  • *
  • Posts: 8
CB not saving Project Linker Settings
« on: June 30, 2019, 04:19:42 pm »
Code::Blocks
Release 17.12 rev 11256
SDK Version: 1.33.0

C/C++ Compiler
(tdm64-1) 5.1.0

Window 10 Home
version 1903
OS build 18362.175

Intel(r) Core(TM) i5-8400 CPU @ 2.80HHz 2.81 GHz

16.0 GB RAM
64 bit

Issue:

Code::Blocks will not save Linker Settings  from the Project->Build options

I have setup both Debug and Release with static libs.
When re-opening Code::Blocks and creating a new project the settings I added are gone. But if I add the static libs then create a new project and the project, when I reopen the project  the settings are present.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11939
    • Travis build status
Re: CB not saving Project Linker Settings
« Reply #1 on: June 30, 2019, 04:34:06 pm »
What happens if you use File -> Save project or File -> Save everything? Where are you storing your project?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline BobsTheDude

  • Single posting newcomer
  • *
  • Posts: 8
Re: CB not saving Project Linker Settings
« Reply #2 on: June 30, 2019, 04:51:14 pm »
I am saving everything to C:\Users\bob\Projects\CodeBlocks\.

If I reopen a project saved from here all of my Link Libraries I added are still in place. If I create a new Project I have to re-add everything again.

I found several other posts with similar issues but none of them worked.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11939
    • Travis build status
Re: CB not saving Project Linker Settings
« Reply #3 on: June 30, 2019, 04:57:23 pm »
This the expected behaviour.
If you want to have specific initial project settings then you have to make project template that works for your case.
If you don't know how to do it open the project wizard and right click on the wizard you're using and there would be an option to edit the wizard script. Then you can add the needed libraries. It is not hard.

http://wiki.codeblocks.org/index.php/Wizard_scripts
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline BobsTheDude

  • Single posting newcomer
  • *
  • Posts: 8
Re: CB not saving Project Linker Settings
« Reply #4 on: June 30, 2019, 05:20:01 pm »
Thank you for your help. Being a Unix guy this was a learning experience for sure.