Author Topic: Program runs a blank screen.  (Read 209 times)

Offline allenlswain

  • Multiple posting newcomer
  • *
  • Posts: 13
Program runs a blank screen.
« on: June 20, 2019, 02:29:47 am »
I am running Code::Blocks version Code::Blocks 17.12 on Windows 10.  The compiler I use is GNU GCC compiler


When I try to run my code, I get a blank window, except for the blinking cursor

Build log:
Code: [Select]
Checking for existence: C:\Users\User\Desktop\Allen's Project\main.exe
Executing: '"C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "C:\Users\User\Desktop\Allen's Project\main.exe"' (in 'C:\Users\User\Desktop\Allen's Project')
Process terminated with status -1073741510 (0 minute(s), 7 second(s))

    (Although the following is not necessary, showing that you
     have tried increases the probability of a response.)
I have already tried following the steps to diagnose a compiler problem, as found here: http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

... but none of them worked.

Occasionally the program will crash as well, when I try to exit Code::Blocks.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2379
Re: Program runs a blank screen.
« Reply #1 on: June 20, 2019, 09:44:17 am »
Code: [Select]
Checking for existence: C:\Users\User\Desktop\Allen's Project\main.exe
Executing: '"C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "C:\Users\User\Desktop\Allen's Project\main.exe"' (in 'C:\Users\User\Desktop\Allen's Project')
Process terminated with status -1073741510 (0 minute(s), 7 second(s))
This means there are no compilation issues, but running issues...
Your code is probably wrong, or some anti virus is blocking the execution...
Have you tried a simple Hello World program? does it work?

Quote
Occasionally the program will crash as well, when I try to exit Code::Blocks.
Does codeblocks crash or your program?
How does this manifest?
Is there a codeblocks.rpt in the installation directory of codeblocks?

Offline allenlswain

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Program runs a blank screen.
« Reply #2 on: June 20, 2019, 03:59:18 pm »
Thank you.  I guess my code was bad.