Author Topic: Error in Linux 'update' script  (Read 229 times)

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2143
Error in Linux 'update' script
« on: May 16, 2019, 05:23:10 pm »
Head rev 11696
On Mint 17.2/64bit the update script gets the error:

Updating Linux version.
./update: 26: ./update: Syntax error: "(" unexpected (expecting "}")

Line 26 contains:
dirs=(16x16 20x20 24x24 28x28 32x32 40x40 48x48 56x56 64x64)

Changing the '()'s to '{}'s solves the problem.

Ticket #827

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11783
    • Travis build status
Re: Error in Linux 'update' script
« Reply #1 on: May 16, 2019, 07:22:11 pm »
I think the proper fix here is to require bash, at least the implementation and features would be the same everywhere...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11783
    • Travis build status
Re: Error in Linux 'update' script
« Reply #2 on: May 16, 2019, 08:12:26 pm »
Fixed... annoying standards...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]