Author Topic: Debugger stops at lines not being flagged  (Read 156 times)

Offline rudolf128

  • Multiple posting newcomer
  • *
  • Posts: 28
Debugger stops at lines not being flagged
« on: March 29, 2019, 06:36:20 am »
That's it. I have a somewhat large program. When trying to debug it by pressing F8, the debugger stops on some lines not marked as breakpoints, especially ones containing a realloc() function. Then, pressing F7, it apparently restarts with each stroke on F7, and after a while, it finally stops, leaving me the impression that something went wrong.

Messages at the first stop:
#17 0x004065bf in insertp () at e:\WavCompil\Synthesizer\main.c:2620
e:\WavCompil\Synthesizer\main.c:2620:66486:beg:0x4065bf

Messages at the final stop:
[debug]> next
[debug]Single stepping until exit from function ntdll!RtlpNtSetValueKey,
[debug]which has no line number information.

The sentences themselves are in the attachment CB.txt

This happens after having run flawlessly from values of "Top" from 0 to 43.

When the error functions are executed, the program ends.
Note: here, variables beginning with an upper case letter are global.
Thanks.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11653
    • Travis build status
Re: Debugger stops at lines not being flagged
« Reply #1 on: March 29, 2019, 08:47:16 am »
@omlk: Please stop the spamming!!!

@rudolf128: Can you enable full log in the debugger and post it? Are you using optimized builds? Have you looked at the callstack? Sometimes gdb on windows wants to step into functions, probably this is the same case.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]