Author Topic: Panel shows only partially in wxz file editor  (Read 1651 times)

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Panel shows only partially in wxz file editor
« on: January 18, 2019, 04:12:28 pm »
Two problems showed up when I ported a project from Windows 7 to Ubuntu 18.04. The versions are wxWidgets 3.0.3, In Ubuntu Code::Blocks version is 16.04.

1) In the wxs WYSIWYG editor I only see 2/3 of the front panel when not scrolling. The bottom 1/3 flashes to visible for as long as I move the verticle scroll bar. Once I stop moving it I the bottom 1/3 disappears and in its place is the panels background color. (see the attached image "Page Bottom Blank in WXS Editor.png"). When run all front panel objects appear.

2) The "Part Data" StaticBoxSizer object's background color is normal in the wxs file editor. But when run the background is black (see the attached image "Black Background When Run.png").

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Panel shows only partially in wxz file editor
« Reply #1 on: January 18, 2019, 05:55:09 pm »
I think the first problem is fixed in 17.12. Can you try to upgrade and see if the bug is still there?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Re: Panel shows only partially in wxz file editor
« Reply #2 on: January 20, 2019, 08:19:33 am »
Thanks for your reply.

The Code::Blocks 16.04 version I used was the version Ubuntu 18.04's  Software application installed. I removed that Code::Blocks installation, downloaded the codeblocks_17.12-1_amd64_stable.tar.xz file from:

https://sourceforge.net/projects/codeblocks/files/Binaries/17.12/Linux/Debian%20stable/codeblocks_17.12-1_amd64_stable.tar.xz/download

, unpacked it, and in the terminal emulater made the directory it was unpacked into the current directory.

I then executed these two commands:
Code: [Select]
sudo apt-get install ./codeblocks_17.12-1_amd64.deb ./codeblocks-common_17.12-1_all.deb ./libcodeblocks0_17.12-1_amd64.deb
sudo apt-get install ./wxsmith-headers_17.12-1_all.deb ./libwxsmithlib0_17.12-1_amd64.deb ./wxsmith-dev_17.12-1_amd64.deb

This installed Code::Blocks, but this installation did not recognize the .wxs file extension. What do I need to do to see the wxs file in the WYSIWYG editor?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Panel shows only partially in wxz file editor
« Reply #3 on: January 20, 2019, 09:57:33 am »
Install the contrib package.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Re: Panel shows only partially in wxz file editor
« Reply #4 on: January 20, 2019, 06:56:02 pm »
I attempted to follow your suggestion and install contrib. Pasted below is my attempt to do so:
Code: [Select]
sudo apt-get install ./codeblocks-contrib-common_17.12-1_all.deb ./codeblocks-wxcontrib-dev_17.12-1_amd64.deb ./codeblocks-contrib_17.12-1_amd64.deb ./codeblocks-libwxcontrib0_17.12-1_amd64.deb ./codeblocks-wxcontrib-headers_17.12-1_all.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'codeblocks-contrib-common' instead of './codeblocks-contrib-common_17.12-1_all.deb'
Note, selecting 'codeblocks-wxcontrib-dev' instead of './codeblocks-wxcontrib-dev_17.12-1_amd64.deb'
Note, selecting 'codeblocks-contrib' instead of './codeblocks-contrib_17.12-1_amd64.deb'
Note, selecting 'codeblocks-libwxcontrib0' instead of './codeblocks-libwxcontrib0_17.12-1_amd64.deb'
Note, selecting 'codeblocks-wxcontrib-headers' instead of './codeblocks-wxcontrib-headers_17.12-1_all.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codeblocks-contrib : Depends: libhunspell-1.4-0 but it is not installable
                      Recommends: valgrind but it is not going to be installed
                      Recommends: cppcheck but it is not going to be installed
                      Recommends: cscope but it is not going to be installed
                      Recommends: cccc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
I do not know what to do about these errors. Please suggest a solution. Why is it selecting something other than the exact packages from my hard drive in the command line? Why would libhunspell-1.4-0 by uninstallable?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Panel shows only partially in wxz file editor
« Reply #5 on: January 21, 2019, 01:39:01 am »
Why would libhunspell-1.4-0 by uninstallable?
Because your distro has moved to newer version of hunspell and this newer version is not compatible.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Re: Panel shows only partially in wxz file editor
« Reply #6 on: January 21, 2019, 03:09:27 am »
How then is the contrib package installed?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Panel shows only partially in wxz file editor
« Reply #7 on: January 21, 2019, 08:38:55 am »
By finding packages compatible with your distro... Or building packages yourself.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Re: Panel shows only partially in wxz file editor
« Reply #8 on: January 21, 2019, 07:32:07 pm »
I have Hunspell 1.6.2 installed. My LibreOffice installation depends on it. The codeblocks-contrib package appears to need the earlier libhunspell-1.4-0 version. So is it going to possible to have both LibreOffice installed, and the WYSIWG wxs editor available, in the latest version of Code::Blocks?

My OS is Ubuntu 18.04.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Panel shows only partially in wxz file editor
« Reply #9 on: January 21, 2019, 09:03:09 pm »
The packages in the download section do not support Ubuntu 18.x as far as I know...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Re: Panel shows only partially in wxz file editor
« Reply #10 on: January 22, 2019, 07:35:17 am »
Then I will have to compile codeblocks and codeblocks-contrib myself?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Panel shows only partially in wxz file editor
« Reply #11 on: January 22, 2019, 08:19:27 am »
Learn how to make packages. It is straight forward and reliable.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Re: Panel shows only partially in wxz file editor
« Reply #12 on: January 22, 2019, 07:19:13 pm »
For this package will it be necessary to compile my own bin files from Code::Blocks source files? Or can preexisting bin files be repackaged to make Code:Blocks fully functional in Ubuntu 18.04?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11899
    • Travis build status
Re: Panel shows only partially in wxz file editor
« Reply #13 on: January 22, 2019, 07:33:11 pm »
Full recompilation is necessary. But everything would be fully automated and at the end you'll have .deb files.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Online BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2425
Re: Panel shows only partially in wxz file editor
« Reply #14 on: January 23, 2019, 01:32:52 am »
@oBFusCATed: can you write a quick tutorial "how to" generate packages form codeblocks source? A collection of commands would be nice...

Offline spflanze

  • Multiple posting newcomer
  • *
  • Posts: 119
Re: Panel shows only partially in wxz file editor
« Reply #15 on: January 25, 2019, 01:25:09 pm »
I attempted to compile and package Code::Blocks by following the instructions at:
http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_Linux

Those instructions failed at the point of the make command under the heading "Building wxWidgets" where I got many repetitions of errors similar to these:

Code: [Select]
In file included from ../src/gtk/dcclient.cpp:46:0:
../src/gtk/bdiag.xbm:6:50: error: narrowing conversion of ‘128’ from ‘int’ to ‘char’ inside { } [-Wnarrowing]
    0x08, 0x08, 0x04, 0x04, 0x02, 0x02, 0x01, 0x01};
                                                  ^
../src/gtk/bdiag.xbm:6:50: error: narrowing conversion of ‘128’ from ‘int’ to ‘char’ inside { } [-Wnarrowing]

What can be done about those "narrowing conversion" errors?

Online BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2425
Re: Panel shows only partially in wxz file editor
« Reply #16 on: January 25, 2019, 02:36:52 pm »
you do not have to build wxWidgets by yourself... Simply install the wxWidgets-dev library from your package manager
Code: [Select]
sudo apt install libwxgtk3.0-dev

i just try to create a package by myself. The steps i had to do was
Code: [Select]
sudo apt install devscript debhelper cdbs
then go to the root folder of the codeblock source (where the "debian" folder is) and run
Code: [Select]
debuild
in the console.
It is currently building. This will probably take some time on my machine and i will report back as soon as it finished...

[edit:] i do not know in how far this builds the contrib plugins, or adds the debugging symbols. I have to find this out...
« Last Edit: January 25, 2019, 02:39:34 pm by BlueHazzard »

Online BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2425
Re: Panel shows only partially in wxz file editor
« Reply #17 on: January 25, 2019, 05:56:14 pm »
it stops with this error:
Code: [Select]
dh_install -pcodeblocks-headers
dh_install: Compatibility levels before 9 are deprecated (level 7 in use)
dh_install: Cannot find (any matches for) "usr/include/codeblocks/tinyxml" (tried in ., debian/tmp)

dh_install: codeblocks-headers missing files: usr/include/codeblocks/tinyxml
dh_install: missing files, aborting
/usr/share/cdbs/1/rules/debhelper.mk:235: recipe for target 'binary-install/codeblocks-headers' failed
make: *** [binary-install/codeblocks-headers] Error 25
dpkg-buildpackage: error: fakeroot debian/rules binary subprocess returned exit status 2
debuild: fatal error at line 1152:
dpkg-buildpackage -rfakeroot -us -uc -ui failed

someone an idea?