Author Topic: [SOLVED] svn:externals to codeblocks-python does not work with subversion 1.11  (Read 158 times)

Offline Yamakuzure

  • Multiple posting newcomer
  • *
  • Posts: 20
When I try to update c::b, I get:
Code: [Select]
Updating '.':

Fetching external item into 'src/plugins/contrib/FortranProject':
External at revision 235.

svn: warning: W205011: Error handling externals definition for 'src/plugins/contrib/PythonPlugins':
svn: warning: W170013: Unable to connect to a repository at URL 'https://github.com/spillz/codeblocks-python/trunk'
At revision 11511.
svn: E205011: Failure occurred processing one or more externals definitions

Well, there is no trunk on GitHub. The clone url is: https://github.com/spillz/codeblocks-python.git

Is there a trick I didn't know? I mean, besides fixing the external?

Thanks alot!
« Last Edit: December 04, 2018, 12:00:29 am by Yamakuzure »

Offline Yamakuzure

  • Multiple posting newcomer
  • *
  • Posts: 20
Re: svn:externals to codeblocks-python does not work with subversion 1.11
« Reply #1 on: December 03, 2018, 09:30:52 pm »
I did some research, and the github documentation says, that the url does not end in /trunk.
So I changed the URL, and tried to checkout directly:
Code: [Select]
trunk/src/plugins/contrib # svn checkout --depth empty https://github.com/spillz/codeblocks-python/ PythonPlugins
svn: E170013: Unable to connect to a repository at URL 'https://github.com/spillz/codeblocks-python'
svn: E175003: The server at 'https://github.com/spillz/codeblocks-python' does not support the HTTP/DAV protocol

This seemed odd, so I downgraded subversion to 1.9.7 (had 1.11.0 beforehand) and now it works:
Code: [Select]
Updating '.':

Fetching external item into 'src/plugins/contrib/FortranProject':
External at revision 235.


Fetching external item into 'src/plugins/contrib/PythonPlugins':
A    src/plugins/contrib/PythonPlugins/branches
A    src/plugins/contrib/PythonPlugins/trunk
A    src/plugins/contrib/PythonPlugins/trunk/.gitignore
(...)
Updated external to revision 400.

At revision 11511.
I tested again after reverting the external url, and that worked, too:

Conclusion: The subversion version 1.11.0 is either unable to handle externals to github, or my installation had a problem.

Offline Yamakuzure

  • Multiple posting newcomer
  • *
  • Posts: 20
Re: svn:externals to codeblocks-python does not work with subversion 1.11
« Reply #2 on: December 04, 2018, 12:00:07 am »
After successfully building Code::Blocks, I updated back to serf-1.3.9 and subversion-1.11.0 and the error is back.

So there is a problem with that version of svn accessing the subversion bridge at github.

Well, at least talking about the problem helped solving it. ;-)

Offline Yamakuzure

  • Multiple posting newcomer
  • *
  • Posts: 20
Just a little follow-up. The subversion crew did some changes to the protocol, so subversion-1.11 can no longer talk to the github subversion bridge, as it does not answer in the correct way.
See: https://svn.haxx.se/users/archive-2018-11/0010.shtml