Author Topic: Problem initiating execution in Debug mode  (Read 224 times)

Offline rudolf128

  • Single posting newcomer
  • *
  • Posts: 7
Problem initiating execution in Debug mode
« on: November 27, 2018, 05:20:37 am »
I used Code::Blocks to develop several programs about 2 years ago, without problems.
Now, trying to continue the development of a program, I got the following when trying to start it:

Active debugger config: GDB/CDB debugger:Default
Building to ensure sources are up-to-date
Selecting target:
Debug
Adding source dir: e:\WavCompil\Composer\
Adding source dir: e:\WavCompil\Composer\
Adding file: e:\WavCompil\Composer\bin\Debug\Composer.exe
Changing directory to: e:/WavCompil/Composer/.
Set variable: PATH=.;C:\Program Files (x86)\CodeBlocks\MinGW\bin;C:\Program Files (x86)\CodeBlocks\MinGW;C:\Program Files (x86)\Intel\TXE Components\TCS;C:\Program Files\Intel\TXE Components\TCS;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files\Intel\TXE Components\DAL;C:\Program Files (x86)\Intel\TXE Components\DAL;C:\Program Files\Intel\TXE Components\IPT;C:\Program Files (x86)\Intel\TXE Components\IPT;C:\Windows\System32\OpenSSH;E:\Euphoria\BIN;E:\Euphoria4\bin;C:\Users\Ricardo\AppData\Local\Microsoft\WindowsApps;E:\Bat

[debug]Command-line: gdb. exe -nx -fullname -quiet  -args e:/WavCompil/Composer/bin/Debug/Composer.exe
[debug]Working dir : e:\WavCompil\Composer

Starting debugger: gdb. exe -nx -fullname -quiet  -args e:/WavCompil/Composer/bin/Debug/Composer.exe
failed

Compiling showed no errors.

I am using now Windows 10 64 bits on a 64 bits machine, while before I had a 32 bits machine and Windows XP, I recall.

Please notice the  blank space in ***gdb. exe*** in the previous to last line of the error report. I think this is the cause of the problem. How can I fix it?
I am running CODE::BLOCKS as it appears in the web page, Build Dec 25 2017, 07:45:27 - wx 2.8(Windows, Unicode) - 32 bits.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2105
Re: Problem initiating execution in Debug mode
« Reply #1 on: November 27, 2018, 09:14:34 am »
Have you rebuild your program first? If you have used a older compiler to compiler the application it may not work with the current gdb.

You can check the gdb.exe in Settings->Debugger->gdb on the left..

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2108
Re: Problem initiating execution in Debug mode
« Reply #2 on: November 27, 2018, 06:29:28 pm »
Select MainMenu/Settings/Debugger/GDB/CDB Debugger/Default

Make sure the Execution Path: entry does not have a blank in it.

Offline rudolf128

  • Single posting newcomer
  • *
  • Posts: 7
Re: Problem initiating execution in Debug mode
« Reply #3 on: December 01, 2018, 02:38:05 am »
Many thanks! By changing the default path as you said, it works fine!