Author Topic: Copying workspace folder  (Read 208 times)

Offline Kat B

  • Single posting newcomer
  • *
  • Posts: 8
Copying workspace folder
« on: November 21, 2018, 05:53:21 am »
Hi! I have a project that works. I would like to copy that to another folder and still be able to compile/link in that project copy. What settings do I need to change where so that the project copy in the new location can still function?

I have copied and renamed the folder, but when loading the project and building, I'm getting errors such as:

Compiling: GatewayWinUSB.c
mingw32-gcc.exe: [incorrect path]/GatewayWinUSB.c -o obj\Debug\GatewayWinUSB.o: No such file or directory
mingw32-gcc.exe: no input files
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

The correct path has a space in it. The working project recognises that space and has no issue. The project copy drops the first part of the path (everything before and including the space).

Surely what I want to do is pretty straightforwards and happens all the time?

Thanks!

Kat
« Last Edit: November 21, 2018, 05:56:58 am by Kat B »

Offline Kat B

  • Single posting newcomer
  • *
  • Posts: 8
Re: Copying workspace folder
« Reply #1 on: November 21, 2018, 05:56:05 am »
Sorry! Not workspace, project.

Also, found the solution to my problem. I 'Saved the project as' and saved it in the new folder. Bob's my uncle and it all works ! :-D
« Last Edit: November 21, 2018, 06:20:40 am by Kat B »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11279
    • Travis build status
Re: Copying workspace folder
« Reply #2 on: November 21, 2018, 08:22:43 am »
Generally you want to setup your project only with relative paths. Then moving the project should work as expected.

What is the path that causes problems?
And where in the project/build options have you set it?

I'm asking to see if this is a bug or misconfiguration.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]