Author Topic: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?  (Read 343 times)

Offline Danois

  • Single posting newcomer
  • *
  • Posts: 8
Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« on: November 20, 2018, 04:00:35 pm »
Installing Code::Blocks from repository works, but the "codeblocks-contrib" package will not install due to a bad dependency (libhunspell-1.4-0) and this causes plugins to be unavailable. Installing Code::Blocks from the downloaded archive works, it will also install codeblocks-contrib with all plugins apparently available in C::B, but when C::B is launched, a warning says something about a plugin that failed to load (libSpellChecker.so). The package "libhunspell-1.6-0" is installed on the system, version 1.4 of that package is unavailable.

How can this be fixed? :)

Offline Miguel Gimenez

  • Almost regular
  • **
  • Posts: 138
Re: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« Reply #1 on: November 20, 2018, 05:24:33 pm »
Do you have package libhunspell-dev installed?

Online stahta01

  • Lives here!
  • ****
  • Posts: 6368
    • My Best Post
Re: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« Reply #2 on: November 20, 2018, 05:49:14 pm »
How can this be fixed? :)

More information is needed!
What distro? And, what version of distro? Just re-read the post title.
Where did you get the package you tried and failed to install?

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11279
    • Travis build status
Re: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« Reply #3 on: November 20, 2018, 07:13:37 pm »
How can this be fixed? :)
Report to ubuntu maintainers/support.
or
Build 17.12 packages from sources yourself.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Danois

  • Single posting newcomer
  • *
  • Posts: 8
Re: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« Reply #4 on: November 20, 2018, 07:16:12 pm »
Yes, I have libhunspell-dev version 1.6.2-1 installed and it makes no difference. First I tried to install C::B from the Ubuntu repos using Discover package manager. Then I downloaded the 64bit deb's from C::B's download section. Installing those with "sudo dpkg -i *.deb" results in a warning about the missing libhunspell 1.4 package, but it installs and all plugins (minus the spell checker) seems to be working OK. I'm not sure if building C::B from source would make a difference? Or what other options there are?

Thanks! :)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11279
    • Travis build status
Re: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« Reply #5 on: November 20, 2018, 07:39:02 pm »
The -dev package is useful only when building from source.
It seems that Ubuntu devs have updated hunspell, but have forgotten to rebuild C::B.
Or you have some repo config issue. We're not ubuntu support forum and we cannot help with this.

Rebuilding from source would definitely help for the hunspell issue.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Danois

  • Single posting newcomer
  • *
  • Posts: 8
Re: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« Reply #6 on: November 21, 2018, 12:26:54 pm »
It seems that Ubuntu devs have updated hunspell, but have forgotten to rebuild C::B. Or you have some repo config issue. We're not ubuntu support forum and we cannot help with this.

Since the downloaded binaries from the C::B site contains the same issues as the packages in the repos, this cannot be an Ubuntu issue only. If I would run command "sudo apt install -f" to fix broken packages, codeblocks-common would be removed and then I would have what is in the repos. I'll try to build C::B from source when time is available and see how it goes! :)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11279
    • Travis build status
Re: Ubuntu 18.04: Bad dependency "libhunspell-1.4-0", wtd?
« Reply #7 on: November 21, 2018, 01:19:36 pm »
We don't provide ubuntu packages on the site as far as I can see, they are meant to work on a Debian.
The packages on the site have been built before the 18.04 release, so it is not surprising that they doesn't work on this version.

Probably we need to do something about this, but generally it is better to use distro provided packages. And if they don't work then you have to report this to the distro maintainers.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]