Author Topic: Problem(s) with compiler settings  (Read 374 times)

Offline FableSix

  • Single posting newcomer
  • *
  • Posts: 3
Problem(s) with compiler settings
« on: November 12, 2018, 07:36:57 am »
Hello there! New user of C::B (well...currently learning C++ by myself) and for some reasons, my compiler settings stopped working. I've looked for solutions but found nothing. Here's what happening.

I first pressed F9 to compile and here is what showed up



Then I've seen that it says Borland as my default compiler (wich is not) so I go in my settings to see if something changed. Here is what I've found



But the problem is when I close this window, I still get that error message and can't compile anything still



I've also checked if my Debugger was correct and it's still correct as you can see



Can someone help me with that? Thanks in advance! :)

PS: I've already uninstalled and re-installed code::blocks
PPS: Yes, Borland is now named 1- No Use...tried to rename it if by any chance he could forget it...didn't worked

Offline Quiss

  • Multiple posting newcomer
  • *
  • Posts: 66
Re: Problem(s) with compiler settings
« Reply #1 on: November 12, 2018, 08:30:07 am »
You should check/change your project's settings; right click project->Build options

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2105
Re: Problem(s) with compiler settings
« Reply #2 on: November 12, 2018, 03:06:48 pm »
Can you please post the configuration file found in
c:\Users\YOURNAME\AppData\Roaming\Codeblocks\default.conf
? You probably can zip it and post the zip archive here.

To come faster to this folder you can enter
Code: [Select]
%appdata%\Codeblocks in the URL control of the explorer and press enter

Offline FableSix

  • Single posting newcomer
  • *
  • Posts: 3
Re: Problem(s) with compiler settings
« Reply #3 on: November 12, 2018, 05:01:31 pm »
Here is my conf settings

Offline FableSix

  • Single posting newcomer
  • *
  • Posts: 3
Re: Problem(s) with compiler settings
« Reply #4 on: November 12, 2018, 05:02:29 pm »
You should check/change your project's settings; right click project->Build options

I've tried it but didn't worked. Thanks anyway!  :'(

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6368
    • My Best Post
Re: Problem(s) with compiler settings
« Reply #5 on: November 12, 2018, 06:07:12 pm »
You should check/change your project's settings; right click project->Build options

I've tried it but didn't worked. Thanks anyway!  :'(

You need to change the project's selected compiler to a valid compiler!

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11279
    • Travis build status
Re: Problem(s) with compiler settings
« Reply #6 on: November 12, 2018, 08:06:50 pm »
What compiler is selected for the target you're building?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2105
Re: Problem(s) with compiler settings
« Reply #7 on: November 12, 2018, 08:30:58 pm »
Your settings file seems to be fine. You probably have messed up somehow your project.

As other have pointed out you probably have to select the right compiler for your project. You can do this with
1) Project->Build options->select the project name on the left->From the drop down menu "Selected compiler" select the "gnu gcc compiler".
2) Now click on each target name in the tree control on the left and check it there is the same compiler selected in the "Selected compiler" option.
3) Close the dialog with OK
4) Save everything with File->Save everything
5) Rebuild your project with Build->Rebuild

If this does not help please post your zipped project file