Author Topic: Errors after executing Code::Blocks  (Read 787 times)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11267
    • Travis build status
Re: Errors after executing Code::Blocks
« Reply #15 on: November 08, 2018, 07:49:39 pm »
These errors are fine. They are printed because the zip files doesn't contain xrc files. But this doesn't affect any functionality as far as I know.

I've asked if something didn't work and you said that there are some plugins that are broken.
Would you be kind enough to tell us what doesn't work (except those messages)?

(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ordak

  • Multiple posting newcomer
  • *
  • Posts: 72
Re: Errors after executing Code::Blocks
« Reply #16 on: November 09, 2018, 02:46:10 pm »
These errors are fine. They are printed because the zip files doesn't contain xrc files. But this doesn't affect any functionality as far as I know.

I've asked if something didn't work and you said that there are some plugins that are broken.
Would you be kind enough to tell us what doesn't work (except those messages)?

For Cccc see the attached image.

Code: [Select]
cccc "Main.c"
Failed to lauch cccc.
cccc "Main.c"
Failed to lauch cccc.
cccc "Main.c"
Failed to lauch cccc.


For instance this is from running valgrind:

Code: [Select]
valgrind --version
execvp(valgrind, --version) failed with error 2!
Setting dynamic linker path to: .:
Executing command: valgrind  --leak-check=full --track-origins=yes --xml=yes "/home/mehdi/Documents/Code_Blocks_Projects/Sudoku_GA/bin/Release/sudoku_GA"

-------------- Application output --------------
execvp(valgrind, --leak-check=full, --track-origins=yes, --xml=yes, /home/mehdi/Documents/Code_Blocks_Projects/Sudoku_GA/bin/Release/sudoku_GA) failed with error 2!


Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11267
    • Travis build status
Re: Errors after executing Code::Blocks
« Reply #17 on: November 09, 2018, 04:18:54 pm »
Do you have both cccc and valgrind installed on you machine? Are they in the PATH?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ordak

  • Multiple posting newcomer
  • *
  • Posts: 72
Re: Errors after executing Code::Blocks
« Reply #18 on: November 10, 2018, 11:15:47 am »
Do you have both cccc and valgrind installed on you machine? Are they in the PATH?

No, they are not installed. I vaguely remember previously (in Code::Blocks)  there was no need to install them, some of these would just work.

Offline ordak

  • Multiple posting newcomer
  • *
  • Posts: 72
Re: Errors after executing Code::Blocks
« Reply #19 on: November 10, 2018, 02:14:14 pm »
I installed cccc through Synaptic Package Manager and after opening a project it runs fine. However I still get this among others:

Code: [Select]
Manager failed to load XRC resource '/usr/local/share/codeblocks/Cccc.zip'.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11267
    • Travis build status
Re: Errors after executing Code::Blocks
« Reply #20 on: November 10, 2018, 02:39:08 pm »
I've already told you to ignore them... :)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]