Author Topic: Re: Debugger Fails, saying ( No symbol table is loaded. Use the "file" command )  (Read 148 times)

Offline jlastofka

  • Single posting newcomer
  • *
  • Posts: 5
I found an easy fix in my case - *after* struggling for a while. I see a lot of talk about this, going back years and years.

I was struggling with it, too, and the changes I was making to the compiler/debugger settings weren't having any effect. Then I realized I had to force the file to actually recompile after changing system settings, by making a trivial change in the source or deleting the executable so the system had to regenerate it. Just changing the compiler/debugger settings or making menu selections in Code::Blocks won't do it. Seems somewhat obvious in hindsight (I think there are even little text reminders in the system dialogs) but perhaps others are in the same boat and will be searching for recent info and might find this tip.

Specifically, in my case, it had been working the day before. Then I think the -g option got turned off in one of the multiple places they have for you to set it. I was searching here, the internet, guessing, changing settings, restarting the computer....    All it took was to get the -g flag set and then forcing the file to recompile...

Offline Yanayoei

  • Single posting newcomer
  • *
  • Posts: 2
Ang site na ito ay itinuturing na lubos na kaalaman, ngunit nais kong malaman kung ang data na ito ay tinanggal at kung bakit.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2062
You can also hit the rebuild button: Build->Rebuild or Build->Clean and Build->Build