Author Topic: undefined reference when linking codeblocks.exe  (Read 3713 times)

Offline iKevin

  • Single posting newcomer
  • *
  • Posts: 6
    • http://
undefined reference when linking codeblocks.exe
« on: April 10, 2005, 02:46:08 pm »
Hi All

I had previously installed codeblocks on gentoo linux from cvs with troubles but the last few checkouts failed to link with the following error:

Code: [Select]

Linking executable devel/codeblocks.exe...
devel/libcodeblocks.so: undefined reference to `vtable for wxSplitPanel'
devel/libcodeblocks.so: undefined reference to `wxSplitPanel::Create(wxWindow*, int, wxPoint const&, wxSize const&, long, wxString const&)'
devel/libcodeblocks.so: undefined reference to `wxSplitPanel::RefreshSplitter(int, int, int)'
collect2: ld returned 1 exit status
make: *** [devel/codeblocks.exe] Error 1


I am linking against wxGTK-2.4.2.  Is there something that I should look for in resolving this issue?

Thanks
Kev

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
undefined reference when linking codeblocks.exe
« Reply #1 on: April 10, 2005, 03:43:21 pm »
Yes, the unix makefile is a little bit off the last couple of days...
I 'll fix this in a while.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline iKevin

  • Single posting newcomer
  • *
  • Posts: 6
    • http://
undefined reference when linking codeblocks.exe
« Reply #2 on: April 10, 2005, 04:08:54 pm »
Thanks Yiannis.
Kevin