Author Topic: Every project stop working  (Read 567 times)

Offline Dave008

  • Single posting newcomer
  • *
  • Posts: 5
Every project stop working
« on: August 07, 2018, 09:55:10 pm »
Hello, I'm new to Codeblocks, so I do not understand what's happening, the fact is that every time I compile and execute any project, I got a screen with this error:

https://img.raymond.cc/blog/wp-content/uploads/2009/08/program_has_stopped_working_error.png

Does anyone know what happens? I install that MinGw thing too but it seems that it did not work for me, thanks in advance, and sorry if my english is bad.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11130
    • Travis build status
Re: Every project stop working
« Reply #1 on: August 08, 2018, 12:26:36 am »
Your application has crashed.
You'll have to use a debugger to find out why.
Does a really simple hello world crash like this?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Dave008

  • Single posting newcomer
  • *
  • Posts: 5
Re: Every project stop working
« Reply #2 on: August 08, 2018, 10:46:15 am »
Your application has crashed.
You'll have to use a debugger to find out why.
Does a really simple hello world crash like this?

Hello, yes, even a simple "hello world" crash like that, the debugging gave me this, which I do not understand very well what it means:

-------------- Run: Debug in test (compiler: GNU GCC Compiler)---------------

Checking for existence: C:\Users\david\Desktop\test\bin\Debug\test.exe
Executing: "C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "C:\Users\david\Desktop\test\bin\Debug\test.exe"  (in C:\Users\david\Desktop\test\.)
Process terminated with status -1073741674 (0 minute(s), 3 second(s)


This is basically what gave me in every project, not only in this one.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11130
    • Travis build status
Re: Every project stop working
« Reply #3 on: August 08, 2018, 01:52:02 pm »
This is not a log from the debugger... Try Debug->Start.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Dave008

  • Single posting newcomer
  • *
  • Posts: 5
Re: Every project stop working
« Reply #4 on: August 08, 2018, 02:18:10 pm »
This is not a log from the debugger... Try Debug->Start.
Active debugger config: GDB/CDB debugger:Default
Building to ensure sources are up-to-date
Selecting target:
Debug
Adding source dir: C:\Users\david\Desktop\test\
Adding source dir: C:\Users\david\Desktop\test\
Adding file: C:\Users\david\Desktop\test\bin\Debug\test.exe
Changing directory to: C:/Users/david/Desktop/test/.
Set variable: PATH=.;C:\MinGW\bin;C:\MinGW;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Users\david\AppData\Local\Microsoft\WindowsApps

[debug]Command-line: C:\MinGW\bin\gdb.exe -nx -fullname -quiet  -args C:/Users/david/Desktop/test/bin/Debug/test.exe
[debug]Working dir : C:\Users\david\Desktop\test

Starting debugger: C:\MinGW\bin\gdb.exe -nx -fullname -quiet  -args C:/Users/david/Desktop/test/bin/Debug/test.exe
done

[debug]> set prompt >>>>>>cb_gdb:

Setting breakpoints

[debug]Reading symbols from C:\Users\david\Desktop\test\bin\Debug\test.exe...done.
[debug](gdb) >>>>>>cb_gdb:
[debug]> show version
[debug]GNU gdb (GDB) 7.6.1
[debug]Copyright (C) 2013 Free Software Foundation, Inc.
[debug]License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
[debug]This is free software: you are free to change and redistribute it.
[debug]There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
[debug]and "show warranty" for details.
[debug]This GDB was configured as "mingw32".
[debug]For bug reporting instructions, please see:
[debug]<http://www.gnu.org/software/gdb/bugs/>.
[debug]>>>>>>cb_gdb:
[debug]> set confirm off

Debugger name and version: GNU gdb (GDB) 7.6.1

[debug]>>>>>>cb_gdb:
[debug]> set width 0
[debug]>>>>>>cb_gdb:
[debug]> set height 0
[debug]>>>>>>cb_gdb:
[debug]> set breakpoint pending on
[debug]>>>>>>cb_gdb:
[debug]> set print asm-demangle on
[debug]>>>>>>cb_gdb:
[debug]> set unwindonsignal on
[debug]>>>>>>cb_gdb:
[debug]> set print elements 200
[debug]>>>>>>cb_gdb:
[debug]> set new-console on
[debug]>>>>>>cb_gdb:
[debug]> set disassembly-flavor att
[debug]>>>>>>cb_gdb:
[debug]> catch throw
[debug]Function "__cxa_throw" not defined.
[debug]Catchpoint 1 (throw)
[debug]>>>>>>cb_gdb:
[debug]> directory C:/Users/david/Desktop/test/
[debug]Source directories searched: C:/Users/david/Desktop/test;$cdir;$cwd
[debug]>>>>>>cb_gdb:
[debug]> run
[debug]Starting program: C:/Users/david/Desktop/test/bin/Debug/test.exe

Child process PID: 5284

[debug][New Thread 5284.0x20f0]
[debug][New Thread 5284.0x2bb4]
[debug][New Thread 5284.0x15f4]
[debug][New Thread 5284.0x276c]
[debug]Program received signal SIGILL, Illegal instruction.
[debug]0x00405066 in std::piecewise_construct ()
[debug]>>>>>>cb_gdb:

Program received signal SIGILL, Illegal instruction.
In std::piecewise_construct () ()

[debug]> bt 30
[debug]#0  0x00405066 in std::piecewise_construct ()
[debug]#1  0x00401498 in _fu0___ZSt4cout () at C:\Users\david\Desktop\test\main.cpp:7
[debug]>>>>>>cb_gdb:
[debug]> frame 1
[debug]#1  0x00401498 in _fu0___ZSt4cout () at C:\Users\david\Desktop\test\main.cpp:7
[debug]C:\Users\david\Desktop\test\main.cpp:7:62:beg:0x401498
[debug]>>>>>>cb_gdb:

#1  0x00401498 in _fu0___ZSt4cout () at C:\Users\david\Desktop\test\main.cpp:7
C:\Users\david\Desktop\test\main.cpp:7:62:beg:0x401498
At C:\Users\david\Desktop\test\main.cpp:7

[debug]> bt 30
[debug]#0  0x00405066 in std::piecewise_construct ()
[debug]#1  0x00401498 in _fu0___ZSt4cout () at C:\Users\david\Desktop\test\main.cpp:7
[debug]>>>>>>cb_gdb:
[debug]> frame 1
[debug]#1  0x00401498 in _fu0___ZSt4cout () at C:\Users\david\Desktop\test\main.cpp:7
[debug]C:\Users\david\Desktop\test\main.cpp:7:62:beg:0x401498
[debug]>>>>>>cb_gdb:

#1  0x00401498 in _fu0___ZSt4cout () at C:\Users\david\Desktop\test\main.cpp:7
C:\Users\david\Desktop\test\main.cpp:7:62:beg:0x401498

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11130
    • Travis build status
Re: Every project stop working
« Reply #5 on: August 08, 2018, 03:29:22 pm »
Your compiler seems broken or inappropriate for your machine (32 vs 64 bit issue).
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Dave008

  • Single posting newcomer
  • *
  • Posts: 5
Re: Every project stop working
« Reply #6 on: August 08, 2018, 03:59:16 pm »
Your compiler seems broken or inappropriate for your machine (32 vs 64 bit issue).
So, what i can do?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6310
    • My Best Post
Re: Every project stop working
« Reply #7 on: August 08, 2018, 04:43:05 pm »
Your compiler seems broken or inappropriate for your machine (32 vs 64 bit issue).
So, what i can do?

Two options I see are:

1. Post the full compiler rebuild log and maybe we can see or confirm the compiler is the problem.http://wiki.codeblocks.org/index.php/FAQ-Compiling_(errors)#Q:_How_do_I_troubleshoot_a_compiler_problem.3F
2. Uninstall the compiler and install a good compiler Edit: The compiler is the "Mingw-like" thing you installed

Tim S.
« Last Edit: August 08, 2018, 05:09:26 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Dave008

  • Single posting newcomer
  • *
  • Posts: 5
Re: Every project stop working
« Reply #8 on: August 08, 2018, 10:18:30 pm »
Quote

Two options I see are:

1. Post the full compiler rebuild log and maybe we can see or confirm the compiler is the problem.http://wiki.codeblocks.org/index.php/FAQ-Compiling_(errors)#Q:_How_do_I_troubleshoot_a_compiler_problem.3F
2. Uninstall the compiler and install a good compiler Edit: The compiler is the "Mingw-like" thing you installed

Tim S.

I reinstall the compiler and now works i don't know how, anyways, thank both of you for answering.