Author Topic: Turn off the extra quote/brace when I type quote/brace  (Read 902 times)

Offline Domarius

  • Single posting newcomer
  • *
  • Posts: 4
Turn off the extra quote/brace when I type quote/brace
« on: August 03, 2018, 11:45:39 pm »
Just a simple thing; When I type a quote, I just want one quote character, not two automatically.

Most times when I'm adding braces or quotes around something, the extra one that helpfully pops up automatically just gets in the way.

How do I turn this feature off?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6298
    • My Best Post
Re: Turn off the extra quote/brace when I type quote/brace
« Reply #1 on: August 04, 2018, 02:13:33 am »
See if this works for you.

Menu: Settings -> Editor
General Settings
Tab: Editor Settings
Section: "Indent Options"
Uncheck "Brace Completion"

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Domarius

  • Single posting newcomer
  • *
  • Posts: 4
Re: Turn off the extra quote/brace when I type quote/brace
« Reply #2 on: August 04, 2018, 03:41:40 pm »
Ah that did it, thank you!

Offline Domarius

  • Single posting newcomer
  • *
  • Posts: 4
Re: Turn off the extra quote/brace when I type quote/brace
« Reply #3 on: August 06, 2018, 11:48:43 pm »
Dammit, the setting is not saving... I had an issue earlier (from adding custom themes) where it wouldn't overwrite default.conf due to permissions, but I fixed that, proven by the fact that the dark theme stays now.

But this setting won't stick... is it in a different file?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11053
    • Travis build status
Re: Turn off the extra quote/brace when I type quote/brace
« Reply #4 on: August 07, 2018, 12:07:00 am »
No, it is in the same file.
Have you tried if other settings are saved correctly?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Domarius

  • Single posting newcomer
  • *
  • Posts: 4
Re: Turn off the extra quote/brace when I type quote/brace
« Reply #5 on: August 07, 2018, 10:39:39 pm »
Hmm it's saving now... I'll have to write that off as something I missed.  Thanks again.

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1981
Re: Turn off the extra quote/brace when I type quote/brace
« Reply #6 on: August 10, 2018, 01:48:50 pm »
You have to press "save-all" for codeblocks to save the settings. Only hitting "OK" is not enough.... Or you need a clean close of codeblocks so it will save it automatically...