User forums > Help

Tabs missing on manager window

(1/2) > >>

greenbreen:
I'm running Codeblocks 17.12 on Ubuntu 18.04.  I'm not sure what I did to cause it, but after working properly for a while, I now only have a "Projects" tab in the management window.  In particular, I'm missing the "Resources" tab that I use to lay out GUIs with wxSmith.

stahta01:

--- Quote from: greenbreen on July 06, 2018, 03:02:45 am ---I'm running Codeblocks 17.12 on Ubuntu 18.04.  I'm not sure what I did to cause it, but after working properly for a while, I now only have a "Projects" tab in the management window.  In particular, I'm missing the "Resources" tab that I use to lay out GUIs with wxSmith.

--- End quote ---

Is the codeblocks contrib package installed?
Is the wxSmith plugin enabled?

Tim S.

greenbreen:
I previously had Codeblocks 16.10 installed via the Ubuntu repositories, but I had an issue with it and so uninstalled it.  I later installed Codeblocks 17.12.  At first I was getting messages about different versions of plugins, or some other similar message, but they eventually went away.  Since everything was working, I didn't think about it further, but I'm guessing the problem I'm seeing now is a result of some conflict between the repository version's dependencies and the current version's dependencies.  I'll try uninstalling everything and reinstalling and post again if I still have an issue.  Thanks for your help!

greenbreen:
I uninstalled everything I could find that was related to Codeblocks and then tried reinstalling, but when I try to create a new wxWidgets project with wxSmith, I get the message, "wxSmith plugin is not loaded, can not continue".  I looked around for how to install wxSmith, but the only information I found is to install "codeblocks-contrib" from the Ubuntu repository.  However, when I try to do that from Synaptic, I get the message,

--- Quote ---codeblocks-contrib:
  Depends: codeblocks (=16.01+dfsg-2.1) but 17.12-1 is to be installed
  Depends: libwxsmithlib0 (=16.01+dfsg-2.1) but 17.12-1 is to be installed

--- End quote ---
, and I am unable to select it.  How can I get the wxSmith plugin for Codeblocks 17.12 for Linux?

greenbreen:
For the benefit of anyone in a similar situation, this is what I did.  When I had installed Codeblocks 17.12 before, I did so using the prebuilt Debian binaries.  I don't know how to get wxSmith for them, so I ended up uninstalling that and building from source.  I find the spell checker to be distracting, so I didn't use "--with-contrib-plugins=all".  I needed to issue
--- Code: ---sudo apt-get install libgamin-dev
--- End code ---
for the FileManager plugin and then I ran
--- Code: ---./configure --with-contrib-plugins=AutoVersioning,BrowseTracker,Cccc,CppCheck,cbkoders,codesnippets,codestat,copystrings,Cscope,DoxyBlocks,dragscroll,EditorConfig,EditorTweaks,envvars,FileManager,headerfixup,help,hexeditor,incsearch,keybinder,libfinder,MouseSap,NassiShneiderman,ProjectOptionsManipulator,profiler,regex,ReopenEditor,exporter,smartindent,symtab,ThreadSearch,ToolsPlus,Valgrind,wxcontrib,wxsmith,wxsmithcontrib,wxsmithaui
--- End code ---
followed by
--- Code: ---make
--- End code ---
and
--- Code: ---sudo make install
--- End code ---
.  I've now got the tabs back on my manager window.

Navigation

[0] Message Index

[#] Next page

Go to full version