Author Topic: AXCODEBLOCKERS installation on Ubuntu 16.04 - make issue  (Read 366 times)

Offline KB1DC

  • Single posting newcomer
  • *
  • Posts: 2
AXCODEBLOCKERS installation on Ubuntu 16.04 - make issue
« on: July 02, 2018, 07:49:46 pm »
Hello:

I guess this is a favor of codeblockes. axcodeblockers is for the AX8052 family by AXSEM now owned by ONSEMI. I downloaded the code at https://github.com/stahta01/axcodeblocks and followed the build instructions. Compiling was successful after installing a couple of dependencies  but during the 'make' the following is what appeared at the end of make.  Not quite sure how to solve this one - clearly I'm not a linux expert. ANY help would be greatly appreciated!!   

Thank you very much!!!


make[4]: Entering directory '/home/jon/Desktop/AXSEM/AX8052 IDE software/axcodeblocks-master/src/sdk/resources'
PWD=`pwd` cd . && zip -qu /home/jon/Desktop/AXSEM/AX8052 IDE software/axcodeblocks-master/src/sdk/resources/manager_resources.zip *.xrc images/*.png images/16x16/*.png images/12x12/*.png > /dev/null
Makefile:801: recipe for target 'manager_resources.zip' failed
make[4]: *** [manager_resources.zip] Error 12
make[4]: Leaving directory '/home/jon/Desktop/AXSEM/AX8052 IDE software/axcodeblocks-master/src/sdk/resources'
Makefile:529: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/home/jon/Desktop/AXSEM/AX8052 IDE software/axcodeblocks-master/src/sdk/resources'
Makefile:1003: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/jon/Desktop/AXSEM/AX8052 IDE software/axcodeblocks-master/src/sdk'
Makefile:531: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/jon/Desktop/AXSEM/AX8052 IDE software/axcodeblocks-master/src'
Makefile:589: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

Offline KB1DC

  • Single posting newcomer
  • *
  • Posts: 2
Re: AXCODEBLOCKERS installation on Ubuntu 16.04 - make issue
« Reply #1 on: July 02, 2018, 11:07:26 pm »
Anyone out there that could help me out  ???

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11144
    • Travis build status
Re: AXCODEBLOCKERS installation on Ubuntu 16.04 - make issue
« Reply #2 on: July 03, 2018, 12:38:27 am »
The real error is missing from the log. You need to find the first line where error is reported.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6320
    • My Best Post
Re: AXCODEBLOCKERS installation on Ubuntu 16.04 - make issue
« Reply #3 on: July 03, 2018, 02:44:42 am »
This repo of mine likely fails to build with configure/make; I am not even sure it builds when using CB project.
I was trying to add features of axcodeblocks to codeblocks when I created this repo. Edit1: I was trying to fork CB and add the files from AX8051 IDE in order to build that version of CB.

I will try configure/make build on Debian and see if it works for me.

Quote
Fork of Code::Blocks IDE with code added from onsemi.com AX8051 IDE forked from Code::Blocks 16.01svn10778

Edit2: I have added more files from the "onsemi.com AX8051 IDE" zip and I am now making it to see if the make error is gone.

Edit3: Link to when I created the repo http://forums.codeblocks.org/index.php?topic=21714.0 It has the URL to download the source code.
Google no longer finds the URL; but, it still finds a PDF and maybe the URL is inside the PDF. I read the PDF when I created the repo; but, I forgot how I found the URL.

Tim S.
 
« Last Edit: July 03, 2018, 06:48:18 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6320
    • My Best Post
Re: AXCODEBLOCKERS installation on Ubuntu 16.04 - make issue
« Reply #4 on: July 03, 2018, 07:42:37 am »
Added 3 commits to testing branch https://github.com/stahta01/axcodeblocks/tree/testing

From the errors, I am guessing that wxWidgets 2.8 was used. No time to fix anymore issues.
You might see if they ever made an wxWidgets 3.0 source download if you wish to use wxWidgets 3.x [to build AxCodeblocks].

Edit: I would suggest using wxWidgets 2.8 unless you wish to convert thier changes to wxWidgets 3.x compatible changes.

Tim S.
« Last Edit: July 04, 2018, 10:38:53 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org