User forums > Help

How to use Code::Blocks and GTK+3

(1/1)

Fl4v1u5:
Running on a Windows 8.1 x64 system.
So I installed codeblocks, and I installed MinGW in to C:\MinGW\ path, then did all the setup to use it.
Then I installed GTK+3 the way it says in the official tutorial, using msys64, using those commands to get the packages, etcetera.
But then I didn't know how to use GTK+3 with Code::Blocks so I used a tutorial and it told me to do lots of wird stuff, which I did, and I followed the tutorial exactly but in order to do so I had to download a different version of GTK and install it to a specific directory and things got messy until eventually I now have installed like three different GTK's....

Now, after completing the tutorial I just created a GTK project and it said the gtk directory seemed fine but couldn't fint gkt.h so I searched for a solution on the internet, which told me I had to modify the project wizard script, which I did (and also done a backup of the original script just in case). Then executed the project and it just said:


--- Quote ----------------- Build: Debug in gtk_practice (compiler: GNU GCC Compiler)---------------

Skipping file (no compiler program set): main.c
Skipping file (no compiler program set): tasmmain.c
Skipping linking (no linker program set): bin\Debug\gtk_practice.exe
Nothing to be done (all items are up-to-date).

--- End quote ---

But as I said I downloaded and set MinGW correctly (I have installed CodeBlocks and MinGW many times doing the same things and everything worked) so after seeing all this mess I decided to go ahead and post this, and to prove my point I created a simple hello world console project, hit build and get the same result as above. Skipping files cause no compiler program was set so now I am completely lost.

I think I may need to reinstall everything and try again.
So how can I correctly configure Code::Blocks to use GTK+3?

BlueHazzard:
Plese post links to the tutorial you used,
also please look at this link: http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_(general)#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

Navigation

[0] Message Index

Go to full version