User forums > Help

[Windows 10] Code::Blocks 'mingw setup.exe' downloads, compiler missing!....

(1/2) > >>

JamieVanCadsand:
Hey Windows 10 and Code::Blocks users...,

I get installed Code::Blocks for Windows 10, including compiler (codeblocks.org / downloads / binery downloads /
mingw setup.exe ).... just i get download the current inclusive compiler version of code::blocks (from the official
site, called codeblocks.org yet)...

Now the download link with buildin compiler was succesfully on Windows XP and Windows 7 yet, but i tryed to
download it on 'Windows 10', with called the same current download link, -mingw setup.exe, on the official codeblocks.org /
downloads / binary downloads / mingw setup.exe- for windows versions..., called on windows 10...

So i get the current incl. compiler version (named mingw setup.exe for windows) downloaded on called Windows 10
and the download on windows 10 was finnished... as follow i open the current download 'code blocks /
mingw setup.exe' on windows 10, called on my computer (where i download it to) and the compiler was't found yet...

If i open 'code::blocks / mingw version' on my computer, called in on windows 10, i still get an environment error thad
said thad the compiler isn't found, but i get realy downloaded the code::blocks / mingw version for windows, normally,
on other windows versions (called Windows XP and Windows 7, the download (called the code::blocks mingw setup.exe)
was succesfully, including the compiler yet... but on Windows 10, i get the same download finnished on my computer,
but the compiler still was not found.

I am an user from the devshed forum and an other user said, thad the code::blocks / windows / mingw setup.exe was
just the current download, they must have an including compiler itself...

see topic: http://forums.devshed.com/programming-42/code-blocks-compiler-found-help-980603.html


So i want to fix this problem, but i don't get any idea, how i can fix this problem yet...
Can anyone help me to fix this problem for windows 10..., the compiler error is not an syntax error, but just an
environment error, thad is called if i starts 'Code::Blocks (downloaded from codeblocks.org / downloads / ... /
binery downloads for windows / mingw setup.exe) on Windows 10, called on my computer...

Just can anyone help me to fix this problem (read the above stand link to the dev shed forums,
before you discusing, pleace) i get ?, thanks for help!,

Jamie.

BlueHazzard:
What is the exact installation path?
Is in your codeblocks installation path a mingw sub folder?
Is in this sub folder a bin folder with gcc.exe?

What if you set the settings in Settings->Compiler->Toolchain executables->Compilers installation directory: Path to the mingw sub folder of codeblocks.

ljcoulthurst:
I have the exact same error.

BlueHazzard:

--- Quote ---I have the exact same error.
--- End quote ---
And you did not add any new information i asked for... So it is impossible to solve this error...

ljcoulthurst:
my installation path is the following..

C:/program_files(x86)/CodeBlocks/
The executable is in that file...codeblocks.exe

There is a folder MinGw/bin and within the bin folder. there is a gcc file however it is not an executable file. it is an application file. however there is no exe extension on it.

I will try the settings as you suggest and post the results here.

Navigation

[0] Message Index

[#] Next page

Go to full version