Author Topic: why the codeblocks-17.12mingw-setup.exe don't have the Mingw updated?  (Read 462 times)

Offline cambalinho

  • Multiple posting newcomer
  • *
  • Posts: 50
why the codeblocks-17.12mingw-setup.exe don't have the Mingw updated?
yes.. i must use the Mingw 7.2.0 version(from Mingw home page) for compile correctly some code.
thank you so much for all

Offline sodev

  • Almost regular
  • **
  • Posts: 163
Because there is no newer version of mingw :P. At least not of TDM-MinGW, and thats the compiler they are currently using to build CodeBlocks. You are talking about MinGW-w64, CodeBlocks can be used with a lot of compiler and they cant make a release for every possible compiler combination.

Offline cambalinho

  • Multiple posting newcomer
  • *
  • Posts: 50
the codeblocks-17.12mingw-setup.exe came with Mingw 5.1.0 version.
but maybe you have right...  the Code Blocks came with 64 bits?
"At least not of TDM-MinGW, and thats the compiler they are currently using to build CodeBlocks."
yes... the 7.2.0 it's from GNU, i think.. thank you so much for the correction