Author Topic: ERROR in 'UniqueString.h:L22' => 'return UniqueString(sNew);'  (Read 127 times)

Offline LETARTARE

  • Regular
  • ***
  • Posts: 353
  • L'ami de l'homme.The friend of man.
hello,
I have long compiled the svn versions with the following configuration
Quote
VISTA Pro business pack 2 (6.0)
'MinGw32-TDM-471' and 'wx-2.8.12'
The latest version without error was svn11321.
The next version svn11322 brings the error in the title.

I'll mention that I will soon try using TDM-510, but I would like to understand why this error occurs.

Here are attached the different elements of the error,
C::B  : svn11313, wxwidgets2.8,  plugins : QtPregen-2.3.0
1-Vista Business Pack 2 32bits :  TDM-GCC 4.7.1, 
2-OpenSuse-42.3-Leap 64bits :  g++-4.8.5,
=> !! The messages are translated by GOOGLE !!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10796
    • Travis build status
Re: ERROR in 'UniqueString.h:L22' => 'return UniqueString(sNew);'
« Reply #1 on: May 06, 2018, 11:21:01 am »
Your compiler doesn't fully support c++11. The minimal compiler version is GCC 4.8, I think (at least it should for on linux).
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline LETARTARE

  • Regular
  • ***
  • Posts: 353
  • L'ami de l'homme.The friend of man.
Re: ERROR in 'UniqueString.h:L22' => 'return UniqueString(sNew);'
« Reply #2 on: May 07, 2018, 11:14:52 am »
@ofuscated
thank you very much, I will test TDM-492 at first.
C::B  : svn11313, wxwidgets2.8,  plugins : QtPregen-2.3.0
1-Vista Business Pack 2 32bits :  TDM-GCC 4.7.1, 
2-OpenSuse-42.3-Leap 64bits :  g++-4.8.5,
=> !! The messages are translated by GOOGLE !!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10796
    • Travis build status
Re: ERROR in 'UniqueString.h:L22' => 'return UniqueString(sNew);'
« Reply #3 on: May 07, 2018, 11:24:50 am »
My advise is to switch directly to  mingw64 7.x.x (for the 64bit version see the wxwidget announcement for the correct version you need to use).
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]