Author Topic: Browse tracker plugin is no more localizable  (Read 1314 times)

Offline gd_on

  • Lives here!
  • ****
  • Posts: 560
Browse tracker plugin is no more localizable
« on: May 02, 2018, 07:54:33 pm »
Browse tracker plugins was localizable a few time ago, but it's no more true. May be because it has been rewriten with wxformbuilder in january 2018.
I see that, for example, in ConfigPanel.cpp each text is configured with wxT(). To be able to translate them, some of them should be set with _(). It was like that in the past, but it's no more the case.
I can make it work, but at the top of ConfigPanel.cpp, it is written "PLEASE DO *NOT* EDIT THIS FILE" : so, I suppose modifications will be lost with a future release.

gd_on
Windows 10, svn C::B (last version or almost!), WxWidgets 3.1.4 (git), Compilers 8.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\MinGW64) or 32 bits (sjlj, posix in C:\MinGW32). Tests and switch to msys2 and gcc 10.1 compilers.

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2250
Re: Browse tracker plugin is no more localizable
« Reply #1 on: May 05, 2018, 05:15:51 pm »
Fixed - SVN 11397
Thanks