Author Topic: [Linux Mint v18.3 sylvia] Install C::B v17.12 !!!  (Read 292 times)

Offline tomay3000

  • Multiple posting newcomer
  • *
  • Posts: 12
[Linux Mint v18.3 sylvia] Install C::B v17.12 !!!
« on: April 02, 2018, 02:08:55 am »
Hello,
Can anyone please tell me how he managed to install C::B v17.12 under Linux Mint v18.3 Sylvia or Ubuntu v16.04.4 LTS (Xenial Xerus), (not from the source code), using jenslody repos, Because I have tried all I have with no avail, and if I continue trying, I will certainly become mad.
I have got lots of dependencies issues.
Code: [Select]
tomay@tomay-Precision-M4700 ~ $ sudo apt-get install codeblocks codeblocks-common libcodeblocks0 codeblocks-dbg codeblocks-contrib codeblocks-libwxcontrib0 codeblocks-contrib-common codeblocks-contrib-dbg codeblocks-dev codeblocks-headers codeblocks-wxcontrib-dev codeblocks-wxcontrib-headers libwxsmithlib0 libwxsmithlib0-dev wxsmith-dev wxsmith-headers
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 codeblocks : Depends: libfontconfig1 (>= 2.12) but 2.11.94-0ubuntu1.1 is to be installed
              Depends: libwxbase3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
              Depends: libwxgtk3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
 codeblocks-contrib : Depends: libboost-system1.62.0 but it is not installable
                      Depends: libfontconfig1 (>= 2.12) but 2.11.94-0ubuntu1.1 is to be installed
                      Depends: libhunspell-1.6-0 but it is not installable
                      Depends: libwxbase3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
                      Depends: libwxgtk3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
 codeblocks-libwxcontrib0 : Depends: libwxbase3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
                            Depends: libwxgtk3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
 libcodeblocks0 : Depends: libwxbase3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
                  Depends: libwxgtk3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
 libwxsmithlib0 : Depends: libwxbase3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
                  Depends: libwxgtk3.0-0v5 (>= 3.0.3.1+dfsg2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Thank you for your understanding.

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 1785
Re: [Linux Mint v18.3 sylvia] Install C::B v17.12 !!!
« Reply #1 on: April 05, 2018, 11:27:49 am »
One possibility would be to compile it from source (not hard: https://github.com/bluehazzard/codeblocks_sf/wiki/build_linux_mint_18)
One possibility would be to complain at the package maintainer at debian/ubuntu that they should update codeblocks to the latest release
One possibility is to use ppa: https://launchpad.net/~pasgui/+archive/ubuntu/ppa/+packages or https://launchpad.net/~damien-moore/+archive/ubuntu/codeblocks-stable or https://launchpad.net/~damien-moore/+archive/ubuntu/codeblocks

Offline tomay3000

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: [Linux Mint v18.3 sylvia] Install C::B v17.12 !!!
« Reply #2 on: April 07, 2018, 02:25:34 am »
I ended up compiling it from source.

Thank you for your help.