Author Topic: Bug Report  (Read 656 times)

Offline Landslyde

  • Multiple posting newcomer
  • *
  • Posts: 38
Bug Report
« on: March 09, 2018, 10:07:11 pm »
Here's the codeblocks.xml and my report of how the crash happened.
Linux Mint 18.3
Code::Blocks svn
GCC 7.1.0

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10838
    • Travis build status
Re: Bug Report
« Reply #1 on: March 09, 2018, 10:46:21 pm »
Generally it is best to post the notes either in the ticket section on sf.net or as a message in the forum.
I can reproduce it...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Landslyde

  • Multiple posting newcomer
  • *
  • Posts: 38
Re: Bug Report
« Reply #2 on: March 09, 2018, 11:18:22 pm »
sf.net. Will do that next time.

Thanks.
Linux Mint 18.3
Code::Blocks svn
GCC 7.1.0

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10838
    • Travis build status
Re: Bug Report
« Reply #3 on: March 10, 2018, 12:19:04 am »
This patch should fix the problem. No idea why it happens, but I don't have more time to spend on this plugin.

The plugin isn't in really good shape.
I was able to trigger several wx assert just clicking randomly.
So it would be good if someone volunteers to clean them up.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Miguel Gimenez

  • Multiple posting newcomer
  • *
  • Posts: 87
Re: Bug Report about Code Snippets
« Reply #4 on: March 21, 2018, 02:21:56 pm »
I have patched two asserts (clicking Settings and clicking About) and cleaned a bit the code (see ticket 644). The attached file contains all the patches posted in that ticket.

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2095
Re: Bug Report about Code Snippets
« Reply #5 on: March 21, 2018, 08:02:51 pm »
I have patched two asserts (clicking Settings and clicking About) and cleaned a bit the code (see ticket 644). The attached file contains all the patches posted in that ticket.

Thanks, I'll have a look at it.

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2095
Re: Bug Report about Code Snippets
« Reply #6 on: March 21, 2018, 08:52:31 pm »
I have patched two asserts (clicking Settings and clicking About) and cleaned a bit the code (see ticket 644). The attached file contains all the patches posted in that ticket.

How did you create this patch. Tortoise SVN refuses to apply it.
What did you use to apply this patch?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10838
    • Travis build status
Re: Bug Report
« Reply #7 on: March 21, 2018, 09:43:07 pm »
He is using git. You have to use patch -p1 < patch.file to apply it.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10838
    • Travis build status
Re: Bug Report
« Reply #8 on: March 22, 2018, 12:33:31 am »
@Pecan: Have you seen my patch for the message box? Do you think I can apply it without loosing functionality?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Miguel Gimenez

  • Multiple posting newcomer
  • *
  • Posts: 87
Re: Bug Report
« Reply #9 on: March 23, 2018, 12:07:36 pm »
I created it with SVN but using the --git option, I will remove it next time.

Thank you for the fix, ticket 644 can be closed.

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2095
Re: Bug Report
« Reply #10 on: March 23, 2018, 08:27:21 pm »
@Pecan: Have you seen my patch for the message box? Do you think I can apply it without loosing functionality?

I fixed the dialogs, but maybe I missed something.
Could you remind me of the ticket you refering to?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10838
    • Travis build status
Re: Bug Report
« Reply #11 on: March 23, 2018, 09:04:13 pm »
I don't know about the tickets. The discussion about this happened mainly here.

So should I remove the GenericMessageDialog or it add something that is not available with the wxMessageDialog?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2095
Re: Bug Report
« Reply #12 on: March 24, 2018, 04:17:05 pm »
I don't know about the tickets. The discussion about this happened mainly here.

So should I remove the GenericMessageDialog or it add something that is not available with the wxMessageDialog?

Thanks, I'll have a look at it.

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2095
Re: Bug Report
« Reply #13 on: March 24, 2018, 10:31:30 pm »
Applied GenericMessageBox patch and cleaned out unused code and dirs
SVN 11346