Author Topic: Warnings while building deb package  (Read 339 times)

Offline Xaviou

  • Regular
  • ***
  • Posts: 274
    • X@v's wxStuff
Warnings while building deb package
« on: January 29, 2018, 11:07:42 am »
Hi

As said in the title, some warnings appears while building the deb package on a debian distro (stretch).
Each dh_strip command give the same warning :
Quote from: debuild
dh_strip: Compatibility levels before 9 are deprecated (level 7 in use)
This is not blocking as the deb package are successfully built, but I would just signal this.

Regards
Xav'
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10797
    • Travis build status
Re: Warnings while building deb package
« Reply #1 on: January 29, 2018, 08:41:23 pm »
Have you tried to rise the compatibility to see what happens?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Xaviou

  • Regular
  • ***
  • Posts: 274
    • X@v's wxStuff
Re: Warnings while building deb package
« Reply #2 on: January 30, 2018, 11:06:16 pm »
Hi
Have you tried to rise the compatibility to see what happens?
Seems to be ok : I've changed "debian/compat" from 7 to 9.
No more warnings and packages build successfully.

Regards
Xav'
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 10797
    • Travis build status
Re: Warnings while building deb package
« Reply #3 on: January 31, 2018, 12:32:21 am »
Can you post a patch? Would this changed source be usable on  other debian based distros? Older ubuntus for example? 16.04 lts, 14.04 lts, etc...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]