Author Topic: Code::Blocks under MacOS 10.12 && 10.13  (Read 465 times)

Offline e.n.c.o.d.e.r.

  • Single posting newcomer
  • *
  • Posts: 1
Code::Blocks under MacOS 10.12 && 10.13
« on: January 08, 2018, 06:27:35 pm »
Dear developers,

I find that the Code::Blocks is a very useful tool to create, develop C++ apps, libs, which can be used under different op. sytems. Plus, Code::Blocks can be run under different op. sytems as well.
I've been using Mac for more than a year, I changed the Win world, that's why I'm missing the Code::Blocks under Mac. Can it be imagined that this new version of Code::Blocks are going to get and download? Or, if it's negative, what should I do to get my dream: Code::Blocks 17.12 under Mac?
Thanks for your reply

Online oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11126
    • Travis build status
Re: Code::Blocks under MacOS 10.12 && 10.13
« Reply #1 on: January 08, 2018, 07:46:24 pm »
There are problems which make cb close to unusable on macOS.
So this is the reason we're not releasing it.

If you really want to try it and even help with fixing problems on macOS, then you could build it yourself.
The current svn trunk should be buildable with XCode 8. For XCode 9 you need to apply a simple patch and it is buildable.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]