User forums > Help

configure: error: Could not find a version of the library!

(1/1)

fusion809:
Hi,

I would like to package Code::Blocks 17.12 for openSUSE Tumbleweed and I'm getting this configure output:


--- Code: ---[   15s] checking whether to build the compiler plugin... yes
[   15s] checking whether to build the debugger plugin... yes
[   15s] checking whether to build the default MIME handler plugin... yes
[   15s] checking whether to build the open files list plugin... yes
[   15s] checking whether to build the occurrences highlighting plugin... yes
[   15s] checking whether to build the foreign projects importer plugin... yes
[   15s] checking whether to build the scripted wizard plugin... yes
[   15s] checking whether to build the to-do plugin... yes
[   15s] checking whether to build the abbreviations plugin... yes
[   15s] checking whether to keep prebuild windows dll's in dist-tarball... yes
[   15s] checking whether to integrate fortran-plugin in dist-tarball... yes
[   15s] checking whether to use gtk-notebook as default notebook... yes
[   15s] checking which (if any) contrib plugins to build... all
[   15s] checking if the compiler supports precompiled headers... yes
[   15s] checking for wx-config... /usr/bin/wx-config
[   15s] checking for wxWidgets version >= 2.8.12... yes (version 3.0.3)
[   15s] checking for wxWidgets static library... no
[   15s] checking for wxWidgets platform... wxGTK
[   15s] checking for GLIB2... yes
[   15s] checking for HUNSPELL... yes
[   15s] configure: gtk2 used
[   15s] checking for GTK... yes
[   15s] checking for GAMIN... yes
[   15s] checking for FONTCONFIG... yes
[   15s] checking for boostlib >=  (102000)... yes
[   15s] checking whether the Boost::System library is available... yes
[   15s] configure: error: Could not find a version of the library!

--- End code ---

boost-devel is listed as a dependency (so it should be satisfied) in its spec file, so I'm confused as to this error. Is there a way to bypass this error? I ask because for openSUSE Leap 42.3 this same spec file builds fine, it seems like the configure script is having a hard time with Tumbleweed. Boost version is 1.66.0, if that is relevant.

Thanks for your time,
Brenton

oBFusCATed:
Do you have boost-system-devel as a package? Can you check the logs for the exact reason why the test has failed?

fusion809:
This is embarrassing. On Leap boost-devel brought in the appropriate system devel package, turns it was all that was missing

jens:
Does it work now ?
If not add:

--- Code: -----with-boost-libdir=%{_libdir}
--- End code ---
to the "configure"-call in the spec-file.

Navigation

[0] Message Index

Go to full version