Author Topic: configure: error: Could not find a version of the library!  (Read 1262 times)

Offline fusion809

  • Single posting newcomer
  • *
  • Posts: 2
configure: error: Could not find a version of the library!
« on: January 06, 2018, 10:49:14 pm »
Hi,

I would like to package Code::Blocks 17.12 for openSUSE Tumbleweed and I'm getting this configure output:

Code: [Select]
[   15s] checking whether to build the compiler plugin... yes
[   15s] checking whether to build the debugger plugin... yes
[   15s] checking whether to build the default MIME handler plugin... yes
[   15s] checking whether to build the open files list plugin... yes
[   15s] checking whether to build the occurrences highlighting plugin... yes
[   15s] checking whether to build the foreign projects importer plugin... yes
[   15s] checking whether to build the scripted wizard plugin... yes
[   15s] checking whether to build the to-do plugin... yes
[   15s] checking whether to build the abbreviations plugin... yes
[   15s] checking whether to keep prebuild windows dll's in dist-tarball... yes
[   15s] checking whether to integrate fortran-plugin in dist-tarball... yes
[   15s] checking whether to use gtk-notebook as default notebook... yes
[   15s] checking which (if any) contrib plugins to build... all
[   15s] checking if the compiler supports precompiled headers... yes
[   15s] checking for wx-config... /usr/bin/wx-config
[   15s] checking for wxWidgets version >= 2.8.12... yes (version 3.0.3)
[   15s] checking for wxWidgets static library... no
[   15s] checking for wxWidgets platform... wxGTK
[   15s] checking for GLIB2... yes
[   15s] checking for HUNSPELL... yes
[   15s] configure: gtk2 used
[   15s] checking for GTK... yes
[   15s] checking for GAMIN... yes
[   15s] checking for FONTCONFIG... yes
[   15s] checking for boostlib >=  (102000)... yes
[   15s] checking whether the Boost::System library is available... yes
[   15s] configure: error: Could not find a version of the library!

boost-devel is listed as a dependency (so it should be satisfied) in its spec file, so I'm confused as to this error. Is there a way to bypass this error? I ask because for openSUSE Leap 42.3 this same spec file builds fine, it seems like the configure script is having a hard time with Tumbleweed. Boost version is 1.66.0, if that is relevant.

Thanks for your time,
Brenton
« Last Edit: January 06, 2018, 11:04:44 pm by fusion809 »

Online oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11126
    • Travis build status
Re: configure: error: Could not find a version of the library!
« Reply #1 on: January 06, 2018, 11:42:05 pm »
Do you have boost-system-devel as a package? Can you check the logs for the exact reason why the test has failed?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline fusion809

  • Single posting newcomer
  • *
  • Posts: 2
Re: configure: error: Could not find a version of the library!
« Reply #2 on: January 07, 2018, 12:09:33 am »
This is embarrassing. On Leap boost-devel brought in the appropriate system devel package, turns it was all that was missing

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7264
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: configure: error: Could not find a version of the library!
« Reply #3 on: January 07, 2018, 12:43:10 am »
Does it work now ?
If not add:
Code: [Select]
--with-boost-libdir=%{_libdir}to the "configure"-call in the spec-file.

Offline jimbo

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: configure: error: Could not find a version of the library!
« Reply #4 on: September 26, 2018, 02:17:54 pm »
Apologies for posting on a older thread,but am seeing exactly this issue with the latest source from svn (as of 26 Sept 2018). All the relevent boost libraries APPEAR to be installed, the log file contains :

Quote
configure:22514: checking for boostlib >=  (102000)
configure:22546: g++ -c -O2 -ffast-math  -Winvalid-pch -DCB_AUTOCONF  -DCB_PRECOMP -I/usr/include conftest.cpp >&5
configure:22546: $? = 0
configure:22548: result: yes
configure:22740: checking whether the Boost::System library is available
configure:22765: g++ -c  -DCB_AUTOCONF  -DCB_PRECOMP -I/usr/include conftest.cpp >&5
configure:22765: $? = 0
configure:22780: result: yes
configure:22939: error: Could not find a version of the library!

What's odd, it says the library is found, but then bombs out. I wonder if there is a gcc version problem? Is there a requried version, I'm on 6.3.0, running on a Raspberry Pi, so an Arm board. I have successfully build the release version (17.12) from source on the same machine, so appears to the version in SVN.

Any ideas?

Jimbo.

Online oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11126
    • Travis build status
Re: configure: error: Could not find a version of the library!
« Reply #5 on: September 26, 2018, 06:00:23 pm »
jimbo: Do you have the boost-dev/boost-devel/equivalent package installed?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jimbo

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: configure: error: Could not find a version of the library!
« Reply #6 on: September 27, 2018, 12:07:07 pm »
Yes,

`sudo apt install libboost-dev`

returns "already the newest version (1.62.0.1+b4)."


Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 2022
Re: configure: error: Could not find a version of the library!
« Reply #7 on: September 27, 2018, 02:23:55 pm »
Isn't boost needed only for the Nassi-Shneiderman plugin? Do you need this plugin?

Offline jimbo

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: configure: error: Could not find a version of the library!
« Reply #8 on: September 27, 2018, 02:32:59 pm »
Isn't boost needed only for the Nassi-Shneiderman plugin? Do you need this plugin?

No idea what it is or does, so probably no! (Going to look it up now...)

edit; No, don't need that one. I pressume that the configure will need editing to remove the boost::system check, then exclude the plugin from the build?
« Last Edit: September 27, 2018, 02:57:14 pm by jimbo »

Online oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11126
    • Travis build status
Re: configure: error: Could not find a version of the library!
« Reply #9 on: September 27, 2018, 07:58:34 pm »
OS/distro?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7264
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: configure: error: Could not find a version of the library!
« Reply #10 on: September 28, 2018, 06:28:23 am »
Isn't boost needed only for the Nassi-Shneiderman plugin? Do you need this plugin?

No idea what it is or does, so probably no! (Going to look it up now...)

edit; No, don't need that one. I pressume that the configure will need editing to remove the boost::system check, then exclude the plugin from the build?
No editing necessary.
Just tell the configure-script you don't want to build NAssiShneiderman should be enough, e.g.:

Code: [Select]
./configure --with-contrib-plugins=all,-NassiShneiderman
would create the makfiles to build all contrib-plugins except for the NAssiShneidermann-plugin.
The boost-check should not be run in this case.

Offline jimbo

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: configure: error: Could not find a version of the library!
« Reply #11 on: September 28, 2018, 11:32:44 am »
Isn't boost needed only for the Nassi-Shneiderman plugin? Do you need this plugin?

No idea what it is or does, so probably no! (Going to look it up now...)

edit; No, don't need that one. I pressume that the configure will need editing to remove the boost::system check, then exclude the plugin from the build?
No editing necessary.
Just tell the configure-script you don't want to build NAssiShneiderman should be enough, e.g.:

Code: [Select]
./configure --with-contrib-plugins=all,-NassiShneiderman
would create the makfiles to build all contrib-plugins except for the NAssiShneidermann-plugin.
The boost-check should not be run in this case.

Thanks, will give that a go.

OS/Distro.  Raspberry Pi running latest Raspbian, a Debian Stretch derivative, uses Kernel 4.14.x running on an Armv7 processor.


Offline jimbo

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: configure: error: Could not find a version of the library!
« Reply #12 on: September 28, 2018, 02:48:20 pm »
Great, that has fixed the build on the Pi and also on my LUbuntu VM (17.10) which was showing a boost::system error during compile rather than during configure. Defo. something screwy with that boost::system stuff.

Thanks.